kernel: update 3.14 to 3.14.10
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2014 18:10:49 +0000 (18:10 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jul 2014 18:10:49 +0000 (18:10 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41533 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/generic/patches-3.14/645-bridge_multicast_to_unicast.patch
target/linux/generic/patches-3.14/811-pci_disable_usb_common_quirks.patch
target/linux/generic/patches-3.14/996-zsmalloc_allow_module_build.patch
target/linux/mvebu/Makefile
target/linux/x86_64/Makefile

index 21b5011..4fc48bf 100644 (file)
@@ -23,8 +23,8 @@ endif
 ifeq ($(LINUX_VERSION),3.13.7)
   LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
 endif
 ifeq ($(LINUX_VERSION),3.13.7)
   LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
 endif
-ifeq ($(LINUX_VERSION),3.14.9)
-  LINUX_KERNEL_MD5SUM:=62b80f9ab490db3bfe0b308a0d3f6f1f
+ifeq ($(LINUX_VERSION),3.14.10)
+  LINUX_KERNEL_MD5SUM:=3ca34a93c59a788d7f573b2660eb5342
 endif
 
 # disable the md5sum check for unknown kernel versions
 endif
 
 # disable the md5sum check for unknown kernel versions
index b550120..a9612f0 100644 (file)
  }
  #endif
  
  }
  #endif
  
-@@ -1465,6 +1492,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1465,6 +1492,7 @@ static int br_multicast_ipv4_rcv(struct
                                 struct sk_buff *skb,
                                 u16 vid)
  {
                                 struct sk_buff *skb,
                                 u16 vid)
  {
        struct sk_buff *skb2 = skb;
        const struct iphdr *iph;
        struct igmphdr *ih;
        struct sk_buff *skb2 = skb;
        const struct iphdr *iph;
        struct igmphdr *ih;
-@@ -1538,7 +1566,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1538,7 +1566,7 @@ static int br_multicast_ipv4_rcv(struct
        case IGMP_HOST_MEMBERSHIP_REPORT:
        case IGMPV2_HOST_MEMBERSHIP_REPORT:
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
        case IGMP_HOST_MEMBERSHIP_REPORT:
        case IGMPV2_HOST_MEMBERSHIP_REPORT:
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
        case IGMPV3_HOST_MEMBERSHIP_REPORT:
                err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
                break;
        case IGMPV3_HOST_MEMBERSHIP_REPORT:
                err = br_ip4_multicast_igmp3_report(br, port, skb2, vid);
-@@ -1547,7 +1575,7 @@ static int br_multicast_ipv4_rcv(struct 
+@@ -1547,7 +1575,7 @@ static int br_multicast_ipv4_rcv(struct
                err = br_ip4_multicast_query(br, port, skb2, vid);
                break;
        case IGMP_HOST_LEAVE_MESSAGE:
                err = br_ip4_multicast_query(br, port, skb2, vid);
                break;
        case IGMP_HOST_LEAVE_MESSAGE:
                break;
        }
  
                break;
        }
  
-@@ -1565,6 +1593,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1565,6 +1593,7 @@ static int br_multicast_ipv6_rcv(struct
                                 struct sk_buff *skb,
                                 u16 vid)
  {
                                 struct sk_buff *skb,
                                 u16 vid)
  {
        struct sk_buff *skb2;
        const struct ipv6hdr *ip6h;
        u8 icmp6_type;
        struct sk_buff *skb2;
        const struct ipv6hdr *ip6h;
        u8 icmp6_type;
-@@ -1674,7 +1703,8 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1674,7 +1703,8 @@ static int br_multicast_ipv6_rcv(struct
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
                BR_INPUT_SKB_CB(skb)->mrouters_only = 1;
                break;
            }
        case ICMPV6_MLD2_REPORT:
                break;
            }
        case ICMPV6_MLD2_REPORT:
-@@ -1691,7 +1721,7 @@ static int br_multicast_ipv6_rcv(struct 
+@@ -1691,7 +1721,7 @@ static int br_multicast_ipv6_rcv(struct
                        goto out;
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
                        goto out;
                }
                mld = (struct mld_msg *)skb_transport_header(skb2);
index 352c814..b85ac69 100644 (file)
@@ -39,7 +39,7 @@
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
-@@ -1070,3 +1085,4 @@ static void quirk_usb_early_handoff(stru
+@@ -1083,3 +1098,4 @@ static void quirk_usb_early_handoff(stru
  }
  DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
                        PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);
  }
  DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
                        PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);
index ea6d444..8ff2b69 100644 (file)
@@ -1,6 +1,6 @@
 --- a/mm/Kconfig
 +++ b/mm/Kconfig
 --- a/mm/Kconfig
 +++ b/mm/Kconfig
-@@ -554,7 +554,7 @@ config MEM_SOFT_DIRTY
+@@ -557,7 +557,7 @@ config MEM_SOFT_DIRTY
          See Documentation/vm/soft-dirty.txt for more details.
  
  config ZSMALLOC
          See Documentation/vm/soft-dirty.txt for more details.
  
  config ZSMALLOC
index 177107c..0252849 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.14.9
+LINUX_VERSION:=3.14.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index f5aa422..6004012 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86_64
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.14.9
+LINUX_VERSION:=3.14.10
 
 KERNELNAME:=bzImage
 
 
 KERNELNAME:=bzImage