target/ixp4xx: fix image building after r20834 (closes: #7157)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Apr 2010 14:36:41 +0000 (14:36 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Apr 2010 14:36:41 +0000 (14:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20854 3c298f89-4303-0410-b956-a3cf2f4a3e73

scripts/arm-magic.sh
target/linux/iop32x/image/Makefile
target/linux/ixp4xx/image/Makefile

index e8f41d3..8bc35c1 100755 (executable)
@@ -34,5 +34,5 @@ do
     printf "\xe3\xa0\x10\x$(echo $hexid|cut -b "2 3")\xe3\x81\x1c\x$(echo $hexid|cut -b 1)" > $BIN_DIR/openwrt-$1-zImage
   fi
     # generate the image
-    cat $BIN_DIR/openwrt-ixp4xx-zImage >> $BIN_DIR/openwrt-$1-zImage
+    cat $BIN_DIR/$IMG_PREFIX-zImage >> $BIN_DIR/openwrt-$1-zImage
 done
index 8086289..1600673 100644 (file)
@@ -16,7 +16,7 @@ define Image/BuildKernel
 #
 # XXX - FIXME
 #
-#      BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
+#      BIN_DIR=$(BIN_DIR) IMG_PREFIX="$(IMG_PREFIX)" $(TOPDIR)/scripts/arm-magic.sh
 endef
 
 define Image/Build
index da8f0fd..6108e91 100644 (file)
@@ -37,7 +37,7 @@ endef
 
 define Image/BuildKernel
        cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
-       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
+       BIN_DIR=$(BIN_DIR) IMG_PREFIX="$(IMG_PREFIX)" $(TOPDIR)/scripts/arm-magic.sh
 endef
 
 define Image/Build