[tools] squashfs: link statically
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Aug 2012 19:26:50 +0000 (19:26 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Aug 2012 19:26:50 +0000 (19:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33105 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/squashfs/Makefile

index c6ad3dd..f4a5460 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -21,6 +21,7 @@ include $(INCLUDE_DIR)/host-build.mk
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
                CC="$(HOSTCC)" \
+               CXX="$(CXX) -static" \
                LZMAPATH=$(STAGING_DIR_HOST)/lib \
                mksquashfs-lzma unsquashfs-lzma 
 endef