base-files: the relinked libpthread needs to be linked against libdl, otherwise calls...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Mar 2011 12:48:36 +0000 (12:48 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Mar 2011 12:48:36 +0000 (12:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25950 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile

index 61296b0..07cc8b4 100644 (file)
@@ -357,7 +357,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
                "$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread_so.a)" \
                "$(patsubst $(TOOLCHAIN_DIR)/lib/%,$(PKG_BUILD_DIR)/%,$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread-*.so))" \
                -Wl,-z,nodelete,-z,initfirst,-init=__pthread_initialize_minimal_internal \
-               $(BUILD_LIBGCC) \
+               -ldl $(BUILD_LIBGCC) \
                -Wl,-soname=libpthread.so.0
   endef
   ifneq ($(BUILD_LIBGCC),)