brcm63xx: Add DT support for HG553
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Aug 2014 11:28:54 +0000 (11:28 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Aug 2014 11:28:54 +0000 (11:28 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
[jogo: fix linux partition length]
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42247 3c298f89-4303-0410-b956-a3cf2f4a3e73

41 files changed:
target/linux/brcm63xx/dts/hg553.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/508-board_hw553.patch
target/linux/brcm63xx/patches-3.14/509-board_rta1320_16m.patch
target/linux/brcm63xx/patches-3.14/510-board_spw303v.patch
target/linux/brcm63xx/patches-3.14/511-board_V2500V.patch
target/linux/brcm63xx/patches-3.14/512-board_BTV2110.patch
target/linux/brcm63xx/patches-3.14/514-board_ct536_ct5621.patch
target/linux/brcm63xx/patches-3.14/516-board_96348A-122.patch
target/linux/brcm63xx/patches-3.14/519_board_CPVA502plus.patch
target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch
target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch
target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch
target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/profiles/huawei.mk

diff --git a/target/linux/brcm63xx/dts/hg553.dts b/target/linux/brcm63xx/dts/hg553.dts
new file mode 100644 (file)
index 0000000..75fec8b
--- /dev/null
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+       model = "Huawei EchoLife HG553";
+       compatible = "huawei,hg553", "brcm,bcm6358";
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x020000>;
+               read-only;
+       };
+
+       linux@20000 {
+               label = "linux";
+               reg = <0x020000 0xfc0000>;
+       };
+
+       nvram@fe0000 {
+               label = "nvram";
+               reg = <0xfe0000 0x020000>;
+       };
+};
index 5b3e06c..b56e27d 100755 (executable)
@@ -57,15 +57,6 @@ define Image/Build/CFEDTB
                $(7) $(8) $(9) $(10)
 endef
 
-define Image/Build/CFEHW553
-       # Generate the tagged image
-       $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
-               --output $(BIN_DIR)/openwrt-$(5)-$(1)-cfe.bin \
-               --boardid $(2) --chipid $(3) --entry $(LOADADDR) \
-               --load-addr $(LOADADDR) --tag-version 7 \
-               --block-size 0x20000 --image-offset $(4)
-endef
-
 define Image/Build/CFEAGPF
        # Generate the tagged image
        $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
@@ -316,9 +307,6 @@ define Image/Build
        # Telsey CPVA642-type (e.g. CPA-ZNTE60T)
        $(call Image/Build/CFE,$(1),CPVA642,6358,CPA-ZNTE60T,,--signature "Telsey Tlc",--signature2 "99.99.999",--second-image-flag "0")
 
-       #HW553
-       $(call Image/Build/CFEHW553,$(1),HW553,6358,0x20000,HW553)
-
        # T-Com Speedport W 303V Typ B
        $(call Image/Build/SPW303V,$(1),96358-502V,6358,SPW303V)
 
@@ -368,6 +356,8 @@ $(eval $(call CfeImageDTB,DSL274XB_C,dsl-274xb-c,AW4139,6358,DSL274XB-C3))
 $(eval $(call CfeImageDTB,DVAG3810BN,dva-g3810bn_tl,96358VW,6358,DVAG3810BN))
 # Huawei HG520v
 $(eval $(call CfeImageDTB,HG520v,hg520v,HW6358GW_B,6358,HG520v,EchoLife_HG520v))
+# Huawei HG553
+$(eval $(call CfeImageDTB,HG553,hg553,HW553,6358,HG553,EchoLife_HG553,--image-offset 0x20000 --block-size 0x20000 --tag-version 7))
 # Huawei HG556a
 $(eval $(call CfeImageDTB,HG556a_AB,hg556a-a,HW556,6358,HG556a_A,EchoLife_HG556a,--image-offset 0x20000 --block-size 0x10000 --tag-version 8))
 $(eval $(call CfeImageDTB,HG556a_AB,hg556a-b,HW556,6358,HG556a_B,EchoLife_HG556a,--image-offset 0x20000 --block-size 0x20000 --tag-version 8))
index 3b26401..6d281ae 100644 (file)
@@ -1,12 +1,13 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1471,6 +1471,83 @@ static struct board_info __initdata boar
+@@ -1471,6 +1471,84 @@ static struct board_info __initdata boar
        .spis = nb4_spi_devices,
        .num_spis = ARRAY_SIZE(nb4_spi_devices),
  };
 +
 +static struct board_info __initdata board_HW553 = {
 +      .name                           = "HW553",
++      .of_board_id                                    = "huawei,hg553",
 +      .expected_cpu_id                = 0x6358,
 +
 +      .has_uart0                      = 1,
@@ -84,7 +85,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -1516,6 +1593,7 @@ static const struct board_info __initcon
+@@ -1516,6 +1594,7 @@ static const struct board_info __initcon
        &board_dsl_274xb_rev_c,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
index 9ce1d25..8349104 100644 (file)
@@ -46,7 +46,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6338 */
  
  /*
-@@ -1564,6 +1603,7 @@ static const struct board_info __initcon
+@@ -1565,6 +1604,7 @@ static const struct board_info __initcon
        &board_96338gw,
        &board_96338w,
        &board_96338w2_e7t,
index 6a8d9c1..8a5c747 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1587,6 +1587,72 @@ static struct board_info __initdata boar
+@@ -1588,6 +1588,72 @@ static struct board_info __initdata boar
                .pci_dev                        = 1,
        },
  };
@@ -73,7 +73,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -1634,6 +1700,7 @@ static const struct board_info __initcon
+@@ -1635,6 +1701,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_HW553,
index 847e816..e96a1a0 100644 (file)
@@ -66,7 +66,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6348 */
  
  /*
-@@ -1688,6 +1747,7 @@ static const struct board_info __initcon
+@@ -1689,6 +1748,7 @@ static const struct board_info __initcon
        &board_96348_D4PW,
        &board_spw500v,
        &board_96348sv,
@@ -74,7 +74,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1726,6 +1786,22 @@ void __init board_bcm963xx_init(void)
+@@ -1727,6 +1787,22 @@ void __init board_bcm963xx_init(void)
                val &= MPI_CSBASE_BASE_MASK;
        }
        boot_addr = (u8 *)KSEG1ADDR(val);
index 20655f9..b9af2da 100644 (file)
@@ -65,7 +65,7 @@
  static struct board_info __initdata board_96348gw = {
        .name                           = "96348GW",
        .of_board_id                    = "brcm,bcm96348gw",
-@@ -1748,6 +1806,7 @@ static const struct board_info __initcon
+@@ -1749,6 +1807,7 @@ static const struct board_info __initcon
        &board_spw500v,
        &board_96348sv,
        &board_V2500V_BB,
index b6e5702..06f2a70 100644 (file)
@@ -60,7 +60,7 @@
  static struct board_info __initdata board_96348gw = {
        .name                           = "96348GW",
        .of_board_id                    = "brcm,bcm96348gw",
-@@ -1807,6 +1860,7 @@ static const struct board_info __initcon
+@@ -1808,6 +1861,7 @@ static const struct board_info __initcon
        &board_96348sv,
        &board_V2500V_BB,
        &board_V2110,
index cc26907..21c2a03 100644 (file)
@@ -78,7 +78,7 @@
  static struct board_info __initdata board_96348gw = {
        .name                           = "96348GW",
        .of_board_id                    = "brcm,bcm96348gw",
-@@ -1864,6 +1935,7 @@ static const struct board_info __initcon
+@@ -1865,6 +1936,7 @@ static const struct board_info __initcon
        &board_V2500V_BB,
        &board_V2110,
        &board_ct536_ct5621,
index 55d1b98..fb5bc60 100644 (file)
@@ -41,7 +41,7 @@
  
  static struct board_info __initdata board_ct536_ct5621 = {
        .name                           = "CT536_CT5621",
-@@ -1937,6 +1971,7 @@ static const struct board_info __initcon
+@@ -1938,6 +1972,7 @@ static const struct board_info __initcon
        &board_V2110,
        &board_ct536_ct5621,
        &board_96348A_122,
index 59075d4..c320f77 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1935,6 +1935,85 @@ static struct board_info __initdata boar
+@@ -1936,6 +1936,85 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
@@ -96,7 +96,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -1986,6 +2065,10 @@ static const struct board_info __initcon
+@@ -1987,6 +2066,10 @@ static const struct board_info __initcon
        &board_HW553,
        &board_spw303v,
  #endif
index 67df6d6..fadf2eb 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2011,6 +2011,72 @@ static struct board_info __initdata boar
+@@ -2012,6 +2012,72 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
@@ -82,7 +82,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -2068,6 +2134,7 @@ static const struct board_info __initcon
+@@ -2069,6 +2135,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
index 074e526..665c71e 100644 (file)
@@ -86,7 +86,7 @@ Subject: [PATCH] MIPS: BCM63XX: add 963281TAN reference board
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2120,6 +2190,7 @@ static const struct board_info __initcon
+@@ -2121,6 +2191,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index b27c234..7b3fba3 100644 (file)
@@ -122,7 +122,7 @@ Subject: [PATCH 70/79] MIPS: BCM63XX: Add board definition for D-Link
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -2191,6 +2296,7 @@ static const struct board_info __initcon
+@@ -2192,6 +2297,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index d0059a6..72542c6 100644 (file)
@@ -60,7 +60,7 @@
  static struct board_info __initdata board_96348_D4PW = {
        .name                           = "D-4P-W",
        .expected_cpu_id                = 0x6348,
-@@ -2326,6 +2379,7 @@ static const struct board_info __initcon
+@@ -2327,6 +2380,7 @@ static const struct board_info __initcon
        &board_ct536_ct5621,
        &board_96348A_122,
        &board_CPVA502plus,
index af1ded3..34a135d 100644 (file)
 +
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
-       .expected_cpu_id                = 0x6358,
-@@ -2391,6 +2516,7 @@ static const struct board_info __initcon
+       .of_board_id                                    = "huawei,hg553",
+@@ -2392,6 +2517,7 @@ static const struct board_info __initcon
        &board_dsl_274xb_rev_c,
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
index bac6247..a245ca1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2317,6 +2317,74 @@ static struct board_info __initdata boar
+@@ -2318,6 +2318,74 @@ static struct board_info __initdata boar
                },
        }
  };
@@ -75,7 +75,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
-@@ -2519,6 +2587,7 @@ static const struct board_info __initcon
+@@ -2520,6 +2588,7 @@ static const struct board_info __initcon
        &board_ct6373_1,
        &board_HW553,
        &board_spw303v,
index 2c7193c..7c0c133 100644 (file)
@@ -17,7 +17,7 @@
  
  #define CT6373_PID_OFFSET             0xff80
  #define CT6373_74X164_GPIO_BASE       64
-@@ -2387,6 +2390,105 @@ static struct board_info __initdata boar
+@@ -2388,6 +2391,105 @@ static struct board_info __initdata boar
  };
  #endif /* CONFIG_BCM63XX_CPU_6358 */
  
  /*
   * known 6368 boards
   */
-@@ -2590,6 +2692,10 @@ static const struct board_info __initcon
+@@ -2591,6 +2693,10 @@ static const struct board_info __initcon
        &board_DVAG3810BN,
  #endif
  
index 86d507f..a505393 100644 (file)
@@ -58,7 +58,7 @@
  static struct board_info __initdata board_rta1025w_16 = {
        .name                           = "RTA1025W_16",
        .of_board_id                    = "dynalink,rta1025w",
-@@ -2663,6 +2714,7 @@ static const struct board_info __initcon
+@@ -2664,6 +2715,7 @@ static const struct board_info __initcon
        &board_96348gw_10,
        &board_96348gw_11,
        &board_FAST2404,
index 272ee64..b85b961 100644 (file)
  static struct board_info __initdata board_dsl_274xb_f1 = {
        .name                           = "AW4339U",
        .expected_cpu_id                = 0x6328,
-@@ -2695,6 +2823,7 @@ static const struct board_info __initcon
+@@ -2696,6 +2824,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
        &board_963281TAN,
index 1ed660d..3194899 100644 (file)
  static struct board_info __initdata board_963281TAN = {
        .name                           = "963281TAN",
        .expected_cpu_id                = 0x6328,
-@@ -2822,6 +2932,7 @@ static const struct board_info __initcon
+@@ -2823,6 +2933,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 93c83af..e80009a 100644 (file)
@@ -93,7 +93,7 @@
  static struct sprom_fixup __initdata ar5387un_fixups[] = {
        { .offset = 2, .value = 0x05bb },
        { .offset = 65, .value = 0x1204 },
-@@ -2932,6 +3018,7 @@ static const struct board_info __initcon
+@@ -2933,6 +3019,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
index 4e46193..e3fa823 100644 (file)
@@ -56,7 +56,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3032,6 +3081,7 @@ static const struct board_info __initcon
+@@ -3033,6 +3082,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
index 1024dce..f6b39c4 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -2679,6 +2680,405 @@ static struct board_info __initdata boar
+@@ -2680,6 +2681,405 @@ static struct board_info __initdata boar
        },
  };
  
   /* T-Home Speedport W 303V Typ B */
  static struct board_info __initdata board_spw303v = {
        .name                   = "96358-502V",
-@@ -3117,6 +3517,9 @@ static const struct board_info __initcon
+@@ -3118,6 +3518,9 @@ static const struct board_info __initcon
        &board_nb4_fxc_r1,
        &board_ct6373_1,
        &board_HW553,
index 5fcb3ba..509e41e 100644 (file)
@@ -61,7 +61,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6345 */
  
  /*
-@@ -3482,6 +3536,7 @@ static const struct board_info __initcon
+@@ -3483,6 +3537,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6345
        &board_96345gw2,
        &board_rta770bw,
index fc8fe62..cd03100 100644 (file)
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
  #endif /* CONFIG_BCM63XX_CPU_6328 */
  
  /*
-@@ -3526,6 +3642,7 @@ static const struct board_info __initcon
+@@ -3527,6 +3643,7 @@ static const struct board_info __initcon
        &board_963281TAN,
        &board_A4001N1,
        &board_dsl_274xb_f1,
index d4ad4e0..cedeac8 100644 (file)
@@ -6,7 +6,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
 ---
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -3481,6 +3481,96 @@ static struct board_info __initdata boar
+@@ -3482,6 +3482,96 @@ static struct board_info __initdata boar
        .devs = nb6_devices,
        .num_devs = ARRAY_SIZE(nb6_devices),
  };
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif /* CONFIG_BCM63XX_CPU_6362 */
  
  /*
-@@ -3698,6 +3788,7 @@ static const struct board_info __initcon
+@@ -3699,6 +3789,7 @@ static const struct board_info __initcon
  
  #ifdef CONFIG_BCM63XX_CPU_6362
        &board_nb6,
index ef33a41..7b9fa91 100644 (file)
@@ -94,7 +94,7 @@
   * known 6328 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3956,6 +4043,9 @@ static const struct board_info __initcon
+@@ -3957,6 +4044,9 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_3368
        &board_cvg834g,
  #endif
index 9723d2a..38fe755 100644 (file)
@@ -95,7 +95,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -4045,6 +4133,7 @@ static const struct board_info __initcon
+@@ -4046,6 +4134,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
index 1e26edf..7a3cea5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4125,6 +4125,75 @@ static struct board_info __initdata boar
+@@ -4126,6 +4126,75 @@ static struct board_info __initdata boar
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
@@ -76,7 +76,7 @@
   * all boards
   */
  static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4205,6 +4274,9 @@ static const struct board_info __initcon
+@@ -4206,6 +4275,9 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
index 2d52047..1d485b6 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
  
  /* BT Voyager 2110 */
  static struct board_info __initdata board_V2110 = {
-@@ -4245,6 +4291,7 @@ static const struct board_info __initcon
+@@ -4246,6 +4292,7 @@ static const struct board_info __initcon
        &board_96348A_122,
        &board_CPVA502plus,
        &board_96348W3,
index 8f46d1b..f92ce6f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4237,6 +4237,108 @@ static struct board_info __initdata boar
+@@ -4238,6 +4238,108 @@ static struct board_info __initdata boar
                },
        },
  };
  #endif /* CONFIG_BCM63XX_CPU_63268 */
  
  /*
-@@ -4323,6 +4425,7 @@ static const struct board_info __initcon
+@@ -4324,6 +4426,7 @@ static const struct board_info __initcon
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
index b020817..d9a704f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4174,6 +4174,131 @@ static struct board_info __initdata boar
+@@ -4175,6 +4175,131 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -4424,6 +4549,7 @@ static const struct board_info __initcon
+@@ -4425,6 +4550,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 428e796..f48eaeb 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/platform_device.h>
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
-@@ -4168,6 +4169,118 @@ static struct board_info __initdata boar
+@@ -4169,6 +4170,118 @@ static struct board_info __initdata boar
        .has_ohci0 = 1,
        .has_ehci0 = 1,
  };
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -4547,6 +4660,7 @@ static const struct board_info __initcon
+@@ -4548,6 +4661,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 29e3a79..61afff6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4170,6 +4170,117 @@ static struct board_info __initdata boar
+@@ -4171,6 +4171,117 @@ static struct board_info __initdata boar
        .has_ehci0 = 1,
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4660,6 +4771,7 @@ static const struct board_info __initcon
+@@ -4661,6 +4772,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index 9a6ac99..7ef72ec 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4281,6 +4281,117 @@ static struct board_info __initdata boar
+@@ -4282,6 +4282,117 @@ static struct board_info __initdata boar
        },
  };
  
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -4772,6 +4883,7 @@ static const struct board_info __initcon
+@@ -4773,6 +4884,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
index 1ed7580..368f28a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4179,6 +4179,96 @@ static struct sprom_fixup __initdata vr3
+@@ -4180,6 +4180,96 @@ static struct sprom_fixup __initdata vr3
        { .offset = 115, .value = 0xfad9 },
  };
  
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .of_board_id                    = "comtrend,vr-3025u",
-@@ -4882,6 +4972,7 @@ static const struct board_info __initcon
+@@ -4883,6 +4973,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
index eb59a40..7ac3220 100644 (file)
@@ -57,8 +57,8 @@
 +
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
-       .expected_cpu_id                = 0x6358,
-@@ -4956,6 +5007,7 @@ static const struct board_info __initcon
+       .of_board_id                                    = "huawei,hg553",
+@@ -4957,6 +5008,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
index 7846aef..09b80b3 100644 (file)
@@ -97,7 +97,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .of_board_id                    = "adb,a4001n1",
-@@ -4958,6 +5048,7 @@ static const struct board_info __initcon
+@@ -4959,6 +5049,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
index 706142d..7188ba3 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -5042,6 +5177,7 @@ static const struct board_info __initcon
+@@ -5043,6 +5178,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 1014884..594389e 100644 (file)
@@ -14,6 +14,16 @@ define Profile/HG520v/Description
 endef
 $(eval $(call Profile,HG520v))
 
+define Profile/HG553
+  NAME:=Huawei EchoLife HG553
+  PACKAGES:=kmod-b43 wpad-mini \
+       kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HG553/Description
+  Package set optimized for Huawei HG553.
+endef
+$(eval $(call Profile,HG553))
+
 define Profile/HG556a_AB
   NAME:=Huawei EchoLife HG556a (version A/B - Atheros)
   PACKAGES:=kmod-ath9k wpad-mini \