handle builddependencies via Config.in, suggested by nbd
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Feb 2005 17:12:19 +0000 (17:12 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Feb 2005 17:12:19 +0000 (17:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@280 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/dropbear_sshd/Config.in
package/dropbear_sshd/dropbear_sshd.mk

index f22f83e..aec730f 100644 (file)
@@ -11,6 +11,9 @@ source "package/dnsmasq/Config.in"
 source "package/iptables/Config.in"
 source "package/bridge/Config.in"
 
+comment "libraries"
+source "package/zlib/Config.in"
+
 comment "Suggested Extras"
 source "package/ebtables/Config.in"
 source "package/dropbear_sshd/Config.in"
index 07c5218..69522fd 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_DROPBEAR_SSHD
        bool "dropbear_sshd"
+       select BR2_PACKAGE_ZLIB
        default n
        help
          A small SSH 2 server designed for small memory environments.
index 4031e21..e5ac5dc 100644 (file)
@@ -67,7 +67,7 @@ $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY): $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SS
        cp $(DROPBEAR_SSHD_DIR)/S50dropbear $(TARGET_DIR)/etc/init.d/
        chmod a+x $(TARGET_DIR)/etc/init.d/S50dropbear
 
-dropbear_sshd: uclibc zlib $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
+dropbear_sshd: uclibc $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
 
 dropbear_sshd-clean:
        $(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \