package/ncurses: fix freebsd install issues
authoracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Nov 2010 17:51:14 +0000 (17:51 +0000)
committeracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Nov 2010 17:51:14 +0000 (17:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24149 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ncurses/Makefile

index 8fac06e..8043588 100644 (file)
@@ -51,11 +51,18 @@ CONFIGURE_ARGS += \
        --without-debug \
        --without-profile \
        --without-progs \
+       --disable-big-core \
+       --disable-home-terminfo \
        --with-normal \
        --with-shared \
        --with-terminfo-dirs=/usr/share/terminfo \
        --with-default-terminfo-dir=/usr/share/terminfo
 
+ifeq ($(HOST_OS),FreeBSD)
+       CONFIGURE_ARGS +=
+               --with-terminfo=/usr/share/terminfo.db 
+endif
+
 ifeq ($(BUILD_VARIANT),libncursesw)
        CONFIGURE_ARGS += \
                --enable-widec \
@@ -78,6 +85,7 @@ endef
 define Package/libncurses/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{curses,ncurses,panel,menu,form}.so* $(1)/usr/lib/
+ifneq ($(HOST_OS),FreeBSD)
        $(INSTALL_DIR) $(1)/usr/share/terminfo
        (cd $(PKG_INSTALL_DIR)/usr/share/terminfo; \
                for dir in ??; do \
@@ -90,6 +98,7 @@ define Package/libncurses/install
                $(CP) $(PKG_INSTALL_DIR)/usr/share/terminfo/$$$$file \
                        $(1)/usr/share/terminfo/$$$$file; \
        done
+endif
 endef
 
 define Package/libncursesw/install