gcc: compile libgcc and libstdc++ with -O2 instead of -Os on power pc to avoid genera...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 27 Oct 2009 01:11:35 +0000 (01:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 27 Oct 2009 01:11:35 +0000 (01:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18177 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/Makefile

index 3b31127..77243c5 100644 (file)
@@ -151,6 +151,10 @@ GCC_CONFIGURE_STAGE2:= \
                --disable-tls \
                --with-slibdir=$(TOOLCHAIN_DIR)/lib \
 
+ifdef CONFIG_powerpc
+  TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
+endif
+
 GCC_MAKE:= \
        export SHELL="$(BASH)"; \
        $(MAKE) \