convert busybox to new packaging style
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 May 2005 19:12:20 +0000 (19:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 May 2005 19:12:20 +0000 (19:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@844 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Makefile
package/busybox/busybox.control [deleted file]
package/busybox/ipkg/busybox.control [new file with mode: 0644]

index ccd7f7b..1b11c87 100644 (file)
@@ -19,45 +19,25 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads
 PKG_MD5SUM:=5c7ea9b5d3b3677dfcdcec38b281a756
 endif
-
 PKG_CAT:=bzcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
-$(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+include $(TOPDIR)/package/rules.mk
 
-$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PATCH) $(PKG_BUILD_DIR) ./patches
-       touch $(PKG_BUILD_DIR)/.patched
+$(eval $(call PKG_template,BUSYBOX,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.patched
+$(PKG_BUILD_DIR)/.configured:
        $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
        yes '' | $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" -C $(PKG_BUILD_DIR) oldconfig
-       touch $(PKG_BUILD_DIR)/.configured
+       touch $@
 
-$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
-       $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" PREFIX="$(PKG_IPK_DIR)" \
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" PREFIX="$(IDIR_BUSYBOX)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR)
+       touch $@
 
-$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" PREFIX="$(PKG_IPK_DIR)" \
+$(IPKG_BUSYBOX):
+       $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" PREFIX="$(IDIR_BUSYBOX)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR) install
-       $(STRIP) $(PKG_IPK_DIR)/bin/busybox
-       -chmod a+x $(PKG_IPK_DIR)/usr/share/udhcpc/default.script
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.patched
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
-
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+       $(STRIP) $(IDIR_BUSYBOX)/bin/busybox
+       -chmod a+x $(IDIR_BUSYBOX)/usr/share/udhcpc/default.script
+       $(IPKG_BUILD) $(IDIR_BUSYBOX) $(PACKAGE_DIR)
diff --git a/package/busybox/busybox.control b/package/busybox/busybox.control
deleted file mode 100644 (file)
index 37dfbf6..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: busybox
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: Core utilities for embedded Linux systems
diff --git a/package/busybox/ipkg/busybox.control b/package/busybox/ipkg/busybox.control
new file mode 100644 (file)
index 0000000..37dfbf6
--- /dev/null
@@ -0,0 +1,6 @@
+Package: busybox
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Core utilities for embedded Linux systems