ebtables: disable rpath
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Feb 2015 11:31:07 +0000 (11:31 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Feb 2015 11:31:07 +0000 (11:31 +0000)
Signed-off-by: Nicolas Thill <nico@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44396 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/ebtables/Makefile
package/network/utils/ebtables/patches/001-no_rpath.patch [new file with mode: 0644]

index 8c2fe2c..214e247 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ebtables
 PKG_VERSION:=2.0.10-4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ebtables
diff --git a/package/network/utils/ebtables/patches/001-no_rpath.patch b/package/network/utils/ebtables/patches/001-no_rpath.patch
new file mode 100644 (file)
index 0000000..d4c13f6
--- /dev/null
@@ -0,0 +1,30 @@
+--- a/Makefile
++++ b/Makefile
+@@ -90,8 +90,7 @@ libebtc.so: $(OBJECTS2)
+       $(CC) -shared $(LDFLAGS) -Wl,-soname,libebtc.so -o libebtc.so -lc $(OBJECTS2)
+ ebtables: $(OBJECTS) ebtables-standalone.o libebtc.so
+-      $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) $(LDFLAGS) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
+-      -Wl,-rpath,$(LIBDIR)
++      $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) $(LDFLAGS) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
+ ebtablesu: ebtablesu.c
+       $(CC) $(CFLAGS) $(PROGSPECSD) $< -o $@
+@@ -100,15 +99,13 @@ ebtablesd.o: ebtablesd.c include/ebtable
+       $(CC) $(CFLAGS) $(PROGSPECSD) -c $< -o $@  -I$(KERNEL_INCLUDES)
+ ebtablesd: $(OBJECTS) ebtablesd.o libebtc.so
+-      $(CC) $(CFLAGS) -o $@ ebtablesd.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
+-      -Wl,-rpath,$(LIBDIR)
++      $(CC) $(CFLAGS) -o $@ ebtablesd.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
+ ebtables-restore.o: ebtables-restore.c include/ebtables_u.h
+       $(CC) $(CFLAGS) $(PROGSPECS) -c $< -o $@  -I$(KERNEL_INCLUDES)
+ ebtables-restore: $(OBJECTS) ebtables-restore.o libebtc.so
+-      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ ebtables-restore.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
+-      -Wl,-rpath,$(LIBDIR)
++      $(CC) $(CFLAGS) $(LDFLAGS) -o $@ ebtables-restore.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI)
+ .PHONY: daemon
+ daemon: ebtablesd ebtablesu