[ramips] share prom code
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Sep 2009 10:04:12 +0000 (10:04 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Sep 2009 10:04:12 +0000 (10:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17466 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/files/arch/mips/ralink/common/Makefile
target/linux/ramips/files/arch/mips/ralink/common/prom.c [new file with mode: 0644]
target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt288x/prom.c [deleted file]
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/prom.c [deleted file]

index 96f348a..c2cf48b 100644 (file)
@@ -7,6 +7,6 @@
 # under the terms of the GNU General Public License version 2 as published
 # by the Free Software Foundation.
 
-obj-y  := setup.o intc.o gpio.o
+obj-y  := prom.o setup.o intc.o gpio.o
 
 obj-$(CONFIG_RALINK_DEV_GPIO_LEDS)     += dev-gpio-leds.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/common/prom.c b/target/linux/ramips/files/arch/mips/ralink/common/prom.c
new file mode 100644 (file)
index 0000000..edc3c5e
--- /dev/null
@@ -0,0 +1,156 @@
+/*
+ *  Ralink SoC specific prom routines
+ *
+ *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/string.h>
+
+#include <asm/bootinfo.h>
+#include <asm/addrspace.h>
+
+#include <asm/mach-ralink/common.h>
+#include <asm/mach-ralink/machine.h>
+#include <ralink_soc.h>
+
+struct board_rec {
+       char                    *name;
+       enum ramips_mach_type   mach_type;
+};
+
+static int ramips_prom_argc __initdata;
+static char **ramips_prom_argv __initdata;
+static char **ramips_prom_envp __initdata;
+
+static struct board_rec boards[] __initdata = {
+       {
+               .name           = "RT-N15",
+               .mach_type      = RAMIPS_MACH_RT_N15,
+       }, {
+               .name           = "WHR-G300N",
+               .mach_type      = RAMIPS_MACH_WHR_G300N,
+       }
+};
+
+static inline void *to_ram_addr(void *addr)
+{
+       u32 base;
+
+       base = KSEG0ADDR(RALINK_SOC_SDRAM_BASE);
+       if (((u32) addr > base) &&
+           ((u32) addr < (base + RALINK_SOC_MEM_SIZE_MAX)))
+               return addr;
+
+       base = KSEG1ADDR(RALINK_SOC_SDRAM_BASE);
+       if (((u32) addr > base) &&
+           ((u32) addr < (base + RALINK_SOC_MEM_SIZE_MAX)))
+               return addr;
+
+       /* some U-Boot variants uses physical addresses */
+       base = RALINK_SOC_SDRAM_BASE;
+       if (((u32) addr > base) &&
+           ((u32) addr < (base + RALINK_SOC_MEM_SIZE_MAX)))
+               return (void *)KSEG0ADDR(addr);
+
+       return NULL;
+}
+
+static __init char *ramips_prom_getargv(const char *name)
+{
+       int len = strlen(name);
+       int i;
+
+       if (!ramips_prom_argv) {
+               printk(KERN_DEBUG "argv=%p is invalid, skipping\n",
+                      ramips_prom_argv);
+               return NULL;
+       }
+
+       for (i = 0; i < ramips_prom_argc; i++) {
+               char *argv = to_ram_addr(ramips_prom_argv[i]);
+
+               if (!argv) {
+                       printk(KERN_DEBUG
+                              "argv[%d]=%p is invalid, skipping\n",
+                              i, ramips_prom_argv[i]);
+                       continue;
+               }
+
+               printk(KERN_DEBUG "argv[%d]: %s\n", i, argv);
+               if (strncmp(name, argv, len) == 0 && (argv)[len] == '=')
+                       return argv + len + 1;
+       }
+
+       return NULL;
+}
+
+static __init char *ramips_prom_getenv(const char *envname)
+{
+#define PROM_MAX_ENVS  256
+       int len = strlen(envname);
+       char **env;
+       int i;
+
+       env = ramips_prom_envp;
+       if (!env) {
+               printk(KERN_DEBUG "envp=%p is not in RAM, skipping\n",
+                      ramips_prom_envp);
+               return NULL;
+       }
+
+       for (i = 0; i < PROM_MAX_ENVS; i++) {
+               char *p = to_ram_addr(env[i]);
+
+               if (!p)
+                       break;
+
+               printk(KERN_DEBUG "env[%d]: %s\n", i, p);
+               if (strncmp(envname, p, len) == 0 && p[len] == '=')
+                       return p + len + 1;
+       }
+
+       return NULL;
+#undef PROM_MAX_ENVS
+}
+
+static __init void find_board_byname(char *name)
+{
+       int i;
+
+       for (i = 0; i < ARRAY_SIZE(boards); i++)
+               if (strcmp(name, boards[i].name) == 0) {
+                       ramips_mach = boards[i].mach_type;
+                       break;
+               }
+}
+
+void __init prom_init(void)
+{
+       char *p;
+
+       printk(KERN_DEBUG
+              "prom: fw_arg0=%08x, fw_arg1=%08x, fw_arg2=%08x, fw_arg3=%08x\n",
+              (unsigned int)fw_arg0, (unsigned int)fw_arg1,
+              (unsigned int)fw_arg2, (unsigned int)fw_arg3);
+
+       ramips_prom_argc = fw_arg0;
+       ramips_prom_argv = to_ram_addr((void *)fw_arg1);
+       ramips_prom_envp = to_ram_addr((void *)fw_arg2);
+
+       p = ramips_prom_getargv("board");
+       if (!p)
+               p = ramips_prom_getenv("board");
+       if (p)
+               find_board_byname(p);
+}
+
+void __init prom_free_prom_memory(void)
+{
+       /* We do not have to prom memory to free */
+}
index cac4187..ab98fac 100644 (file)
@@ -8,7 +8,7 @@
 # under the terms of the GNU General Public License version 2 as published
 # by the Free Software Foundation.
 
-obj-y  := prom.o irq.o setup.o rt288x.o devices.o
+obj-y  := irq.o setup.o rt288x.o devices.o
 
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
 
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt288x/prom.c b/target/linux/ramips/files/arch/mips/ralink/rt288x/prom.c
deleted file mode 100644 (file)
index 8becfc9..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-/*
- *  Ralink RT288x SoC specific prom routines
- *
- *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
- *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
- *
- *  This program is free software; you can redistribute it and/or modify it
- *  under the terms of the GNU General Public License version 2 as published
- *  by the Free Software Foundation.
- */
-
-#include <linux/kernel.h>
-#include <linux/init.h>
-#include <linux/io.h>
-#include <linux/serial_reg.h>
-
-#include <asm/bootinfo.h>
-#include <asm/addrspace.h>
-
-#include <asm/mach-ralink/rt288x.h>
-#include <asm/mach-ralink/rt288x_regs.h>
-
-void __init prom_init(void)
-{
-       printk(KERN_DEBUG "prom: fw_arg0=%08x, fw_arg1=%08x, "
-                       "fw_arg2=%08x, fw_arg3=%08x\n",
-                       (unsigned int)fw_arg0, (unsigned int)fw_arg1,
-                       (unsigned int)fw_arg2, (unsigned int)fw_arg3);
-}
-
-void __init prom_free_prom_memory(void)
-{
-       /* We do not have to prom memory to free */
-}
-
index 52231fd..c7c1c31 100644 (file)
@@ -7,7 +7,7 @@
 # under the terms of the GNU General Public License version 2 as published
 # by the Free Software Foundation.
 
-obj-y  := prom.o irq.o setup.o devices.o rt305x.o
+obj-y  := irq.o setup.o devices.o rt305x.o
 
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
 
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/prom.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/prom.c
deleted file mode 100644 (file)
index 774291a..0000000
+++ /dev/null
@@ -1,145 +0,0 @@
-/*
- *  Ralink RT305x SoC specific prom routines
- *
- *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
- *
- *  This program is free software; you can redistribute it and/or modify it
- *  under the terms of the GNU General Public License version 2 as published
- *  by the Free Software Foundation.
- */
-
-#include <linux/kernel.h>
-#include <linux/init.h>
-
-#include <asm/bootinfo.h>
-
-#include <asm/mach-ralink/common.h>
-#include <asm/mach-ralink/machine.h>
-#include <asm/mach-ralink/rt305x.h>
-#include <asm/mach-ralink/rt305x_regs.h>
-
-struct board_rec {
-       char                    *name;
-       enum ramips_mach_type   mach_type;
-};
-
-static int rt305x_prom_argc __initdata;
-static char **rt305x_prom_argv __initdata;
-static char **rt305x_prom_envp __initdata;
-
-static struct board_rec boards[] __initdata = {
-       {
-               .name           = "WHR-G300N",
-               .mach_type      = RAMIPS_MACH_WHR_G300N,
-       }
-};
-
-static inline void *to_ram_addr(void *addr)
-{
-       u32 base;
-
-       base = KSEG0ADDR(RT305X_SDRAM_BASE);
-       if (((u32) addr > base) &&
-           ((u32) addr < (base + RT305X_MEM_SIZE_MAX)))
-               return addr;
-
-       base = KSEG1ADDR(RT305X_SDRAM_BASE);
-       if (((u32) addr > base) &&
-           ((u32) addr < (base + RT305X_MEM_SIZE_MAX)))
-               return addr;
-
-       /* some U-Boot variants uses physical addresses */
-       base = RT305X_SDRAM_BASE;
-       if (((u32) addr > base) &&
-           ((u32) addr < (base + RT305X_MEM_SIZE_MAX)))
-               return (void *)KSEG0ADDR(addr);
-
-       return NULL;
-}
-
-static __init char *rt305x_prom_getargv(const char *name)
-{
-       int len = strlen(name);
-       int i;
-
-       if (!rt305x_prom_argv) {
-               printk(KERN_DEBUG "argv=%p is invalid, skipping\n",
-                      rt305x_prom_argv);
-               return NULL;
-       }
-
-       for (i = 0; i < rt305x_prom_argc; i++) {
-               char *argv = to_ram_addr(rt305x_prom_argv[i]);
-
-               if (!argv) {
-                       printk(KERN_DEBUG
-                              "argv[%d]=%p is invalid, skipping\n",
-                              i, rt305x_prom_argv[i]);
-                       continue;
-               }
-
-               printk(KERN_DEBUG "argv[i]: %s\n", argv);
-               if (strncmp(name, argv, len) == 0 && (argv)[len] == '=')
-                       return argv + len + 1;
-       }
-
-       return NULL;
-}
-
-static __init char *rt305x_prom_getenv(const char *envname)
-{
-       int len = strlen(envname);
-       char **env;
-       char *p;
-
-       env = rt305x_prom_envp;
-       if (!env) {
-               printk(KERN_DEBUG "envp=%p is not in RAM, skipping\n",
-                      rt305x_prom_envp);
-               return NULL;
-       }
-
-       for (p = to_ram_addr(*env); p; env++) {
-               printk(KERN_DEBUG "env: %s\n", *env);
-               if (strncmp(envname, p, len) == 0 && (p)[len] == '=')
-                       return p + len + 1;
-       }
-
-       return NULL;
-}
-
-static __init void find_board_byname(char *name)
-{
-       int i;
-
-       for (i = 0; i < ARRAY_SIZE(boards); i++)
-               if (strcmp(name, boards[i].name) == 0) {
-                       ramips_mach = boards[i].mach_type;
-                       break;
-               }
-}
-
-void __init prom_init(void)
-{
-       char *p;
-
-       printk(KERN_DEBUG
-              "prom: fw_arg0=%08x, fw_arg1=%08x, fw_arg2=%08x, fw_arg3=%08x\n",
-              (unsigned int)fw_arg0, (unsigned int)fw_arg1,
-              (unsigned int)fw_arg2, (unsigned int)fw_arg3);
-
-       rt305x_prom_argc = fw_arg0;
-       rt305x_prom_argv = to_ram_addr((void *)fw_arg1);
-       rt305x_prom_envp = to_ram_addr((void *)fw_arg2);
-
-       p = rt305x_prom_getargv("board");
-       if (!p)
-               p = rt305x_prom_getenv("board");
-       if (p)
-               find_board_byname(p);
-}
-
-void __init prom_free_prom_memory(void)
-{
-       /* We do not have to prom memory to free */
-}