[rdc] use host-side lzma decompression tool, lzma-4.32 from openwrt produces non...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Nov 2009 08:42:41 +0000 (08:42 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Nov 2009 08:42:41 +0000 (08:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18325 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/rdc/Makefile
target/linux/rdc/config-2.6.30
target/linux/rdc/patches-2.6.30/011-use_host_lzma.patch [new file with mode: 0644]

index 185b67a..9936b68 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=RDC 321x
 FEATURES:=squashfs jffs2 pci usb
 CFLAGS:=-Os -pipe -march=i486 -funit-at-a-time
 
-LINUX_VERSION:=2.6.28.10
+LINUX_VERSION:=2.6.30.9
 
 include $(INCLUDE_DIR)/target.mk
 
index 5c2a715..c83aaa5 100644 (file)
@@ -60,8 +60,7 @@ CONFIG_DEVPORT=y
 # CONFIG_DMA_API_DEBUG is not set
 # CONFIG_DMI is not set
 CONFIG_DOUBLEFAULT=y
-CONFIG_EARLY_PRINTK=y
-# CONFIG_EARLY_PRINTK_DBGP is not set
+# CONFIG_EARLY_PRINTK is not set
 # CONFIG_EDAC is not set
 # CONFIG_EDD is not set
 # CONFIG_EUROTECH_WDT is not set
@@ -302,7 +301,7 @@ CONFIG_X86_RDC321X=y
 CONFIG_X86_REBOOTFIXUPS=y
 # CONFIG_X86_RESERVE_LOW_64K is not set
 # CONFIG_X86_UP_APIC is not set
-CONFIG_X86_VERBOSE_BOOTUP=y
+# CONFIG_X86_VERBOSE_BOOTUP is not set
 CONFIG_X86_WP_WORKS_OK=y
 CONFIG_X86_XADD=y
 # CONFIG_ZONE_DMA32 is not set
diff --git a/target/linux/rdc/patches-2.6.30/011-use_host_lzma.patch b/target/linux/rdc/patches-2.6.30/011-use_host_lzma.patch
new file mode 100644 (file)
index 0000000..5def739
--- /dev/null
@@ -0,0 +1,8 @@
+--- a/scripts/Makefile.lib     2009-11-06 08:55:20.000000000 +0100
++++ b/scripts/Makefile.lib     2009-11-06 09:08:45.000000000 +0100
+@@ -204,4 +204,4 @@
+ # ---------------------------------------------------------------------------
+ quiet_cmd_lzma = LZMA    $@
+-cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2 -eos
++cmd_lzma = (/usr/bin/lzma -9 -c $< ; $(size_append) $<) >$@ || (rm -f $@ ; false)