[package] kernel: fix kmod-gre for Kernel >= 2.6.37 (#9009)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Mar 2011 21:57:03 +0000 (21:57 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Mar 2011 21:57:03 +0000 (21:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25985 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netsupport.mk

index 0988ba8..29d5d15 100644 (file)
@@ -370,8 +370,10 @@ $(eval $(call KernelPackage,ip6-tunnel))
 define KernelPackage/gre
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=GRE support
-  KCONFIG:=CONFIG_NET_IPGRE
-  FILES=$(LINUX_DIR)/net/ipv4/ip_gre.ko
+  KCONFIG:=CONFIG_NET_IPGRE \
+    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
+  FILES=$(LINUX_DIR)/net/ipv4/ip_gre.ko \
+    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
 endef
 
 define KernelPackage/gre/description