bugfix in package/rules.mk, add support for dumping package information with make...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 Apr 2006 23:14:13 +0000 (23:14 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 Apr 2006 23:14:13 +0000 (23:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3674 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Config.in [deleted file]
package/busybox/Makefile
package/iptables/Makefile
package/rules.mk

diff --git a/package/busybox/Config.in b/package/busybox/Config.in
deleted file mode 100644 (file)
index e79aef7..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-menu "busybox........................... The Swiss Army Knife of embedded Linux"
-
-config BR2_PACKAGE_BUSYBOX
-       prompt "busybox........................... The Swiss Army Knife of embedded Linux"
-       bool
-       default y
-       help
-         The Swiss Army Knife of embedded Linux.  It slices, it dices, it
-         makes Julian Fries.
-         
-         http://busybox.net/
-         
-         Most people will answer Y.
-
-config BR2_PACKAGE_BUSYBOX_SNAPSHOT
-       bool "Use the daily snapshot of busybox?"
-       depends BR2_PACKAGE_BUSYBOX
-       depends CONFIG_DEVEL
-       default n
-       help
-         Use the latest busybox CVS snapshot instead of release.
-         
-         For fun, you should say Y.
-
-menu "Busybox Configuration"
-       depends BR2_PACKAGE_BUSYBOX
-
-source package/busybox/config/Config.in
-
-endmenu
-
-endmenu
index d1ce289..aa6093e 100644 (file)
@@ -19,6 +19,9 @@ CONFIGFILE:=config/Config.in
 SECTION:=base
 CATEGORY:=Base system
 TITLE:=Core utilities for embedded Linux
+DESCRIPTION:=The Swiss Army Knife of embedded Linux.  It slices, it dices, it\\\
+makes Julian Fries.
+URL:=http://busybox.net
 endef
 
 define Build/Configure
index ded4816..56ab594 100644 (file)
@@ -20,13 +20,16 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 PKG_MENU:=IPv4 / IPv6 firewall administration
 
 include $(TOPDIR)/package/rules.mk
+ifeq ($(DUMP),)
 include $(LINUX_DIR)/.config
 include $(TOPDIR)/target/linux/netfilter.mk
+endif
 
 define Package/iptables
 SECTION:=net
 CATEGORY:=Base system
 TITLE:=IPv4 firewall administration tool
+URL:=http://netfilter.org/
 endef
 
 define Package/iptables-mod-conntrack
index c2f0a34..9f52f17 100644 (file)
@@ -1,5 +1,9 @@
 # default target
+ifneq ($(DUMP),)
+all: dumpinfo
+else
 all: compile
+endif
 
 define Build/DefaultTargets
 $(PKG_BUILD_DIR)/.prepared:
@@ -71,15 +75,15 @@ IDEPEND_$(1):=$$(strip $$(DEPENDS))
 $$(IDIR_$(1))/CONTROL/control: $(PKG_BUILD_DIR)/.prepared
        mkdir -p $$(IDIR_$(1))/CONTROL
        echo "Package: $(1)" > $$(IDIR_$(1))/CONTROL/control
-       echo "Version: $$(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Version: $(VERSION)" >> $$(IDIR_$(1))/CONTROL/control
        echo "Depends: $$(IDEPEND_$(1))" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Source: $$(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Section: $$(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Priority: $$(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Maintainer: $$(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Architecture: $$(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "Description: $$(TITLE)" >> $$(IDIR_$(1))/CONTROL/control
-       echo "$$(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
+       echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Maintainer: $(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Architecture: $(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "Description: $(TITLE)" >> $$(IDIR_$(1))/CONTROL/control
+       echo "$(DESCRIPTION)" | sed -e 's,\\,\n ,g' >> $$(IDIR_$(1))/CONTROL/control
        chmod 644 $$(IDIR_$(1))/CONTROL/control
        for file in conffiles preinst postinst prerm postrm; do \
                [ -f ./ipkg/$(1).$$$$file ] && cp ./ipkg/$(1).$$$$file $$(IDIR_$(1))/CONTROL/$$$$file || true; \
@@ -96,6 +100,18 @@ $(1)-clean:
        rm -f $$(IPKG_$(1))
 clean: $(1)-clean
 
+DUMPINFO += \
+       echo "Package: $(1)"; \
+       echo "Version: $(VERSION)"; \
+       echo "Depends: $(IDEPEND_$(1))"; \
+       echo "Title: $(TITLE)"; \
+       echo "$(DESCRIPTION)" | sed -e 's,\\,\n,g'; \
+       echo; \
+       echo "$(URL)"; \
+       echo "@@";
+
+PACKAGES += $(1)
+
 ifneq ($(__DEFAULT_TARGETS),1)
 $(eval $(call Build/DefaultTargets))
 endif
@@ -143,6 +159,11 @@ define Build/Compile
 $(call Build/Compile/Default)
 endef
 
+ifneq ($(DUMP),)
+dumpinfo:
+       $(DUMPINFO)
+else
+
 source: $(DL_DIR)/$(PKG_SOURCE)
 prepare: source
        @[ -f $(PKG_BUILD_DIR)/.prepared ] || { \
@@ -183,5 +204,6 @@ clean:
        @$(CMD_TRACE) "cleaning... " 
        @$(MAKE) clean-targets $(MAKE_TRACE)
        rm -rf $(PKG_BUILD_DIR)
+endif
 
-.PHONY: all source prepare compile install clean
+.PHONY: all source prepare compile install clean dumpinfo