package/busybox: add upstream hush patch, bump release number
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 May 2010 14:00:43 +0000 (14:00 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 May 2010 14:00:43 +0000 (14:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21545 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Makefile
package/busybox/patches/000-upstream-hush.patch [new file with mode: 0644]

index 60daf8d..3a06ad0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.16.1
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
diff --git a/package/busybox/patches/000-upstream-hush.patch b/package/busybox/patches/000-upstream-hush.patch
new file mode 100644 (file)
index 0000000..1e038bf
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/shell/hush.c
++++ b/shell/hush.c
+@@ -6944,7 +6944,7 @@ int hush_main(int argc, char **argv)
+                               /* -c 'script' (no params): prevent empty $0 */
+                               G.global_argv--; /* points to argv[i] of 'script' */
+                               G.global_argv[0] = argv[0];
+-                              G.global_argc--;
++                              G.global_argc++;
+                       } /* else -c 'script' ARG0 [ARG1...]: $0 is ARG0 */
+                       init_sigmasks();
+                       parse_and_run_string(optarg);