The name gpio-cs5535 used to refer to the drivers/char/ module, but in 3.1 it refers...
authorcshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Oct 2011 03:04:11 +0000 (03:04 +0000)
committercshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Oct 2011 03:04:11 +0000 (03:04 +0000)
Philip Prindeville - 2011-08-29 04:55:59

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28354 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index 1e252e3..91fc17c 100644 (file)
@@ -160,8 +160,13 @@ define KernelPackage/gpio-cs5535-new
   TITLE:=AMD CS5535/CS5536 GPIO driver with improved sysfs support
   DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32)
   KCONFIG:=CONFIG_GPIO_CS5535
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+  FILES:=$(LINUX_DIR)/drivers/gpio/gpio-cs5535.ko
+  AUTOLOAD:=$(call AutoLoad,50,gpio-cs5535)
+else
   FILES:=$(LINUX_DIR)/drivers/gpio/cs5535-gpio.ko
   AUTOLOAD:=$(call AutoLoad,50,cs5535-gpio)
+endif
 endef
 
 define KernelPackage/gpio-cs5535-new/description