ixp4xx: don't leave zImage on the rootfs for images other than the freecom one
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Apr 2009 10:29:40 +0000 (10:29 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Apr 2009 10:29:40 +0000 (10:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15117 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ixp4xx/image/Makefile

index 82f2e96..b1c715a 100644 (file)
@@ -30,6 +30,7 @@ define Image/Build/Freecom
        $(INSTALL_DIR) $(TARGET_DIR)/var
        $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
        $(STAGING_DIR_HOST)/bin/encode_crc $(BIN_DIR)/openwrt-$(2)-$(1).img $(BIN_DIR)/openwrt-$(2)-$(1)-webupgrade.img
+       rm -f $(TARGET_DIR)/zImage
 endef
 
 define Image/Prepare