Port kmod-tun to the new module layout
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Aug 2006 19:43:53 +0000 (19:43 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Aug 2006 19:43:53 +0000 (19:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4633 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/modules-2.6.mk
package/kernel/modules.mk
target/linux/Config.in

index 70a1fcc..08ac4da 100644 (file)
@@ -23,10 +23,6 @@ $(eval $(call KMOD_template,SCHED,sched,\
        $(MODULES_DIR)/kernel/net/sched/*.ko \
 ,CONFIG_NET_SCHED))
 
-$(eval $(call KMOD_template,TUN,tun,\
-       $(MODULES_DIR)/kernel/drivers/net/tun.ko \
-,CONFIG_TUN,,20,tun))
-
 # Block devices
 
 $(eval $(call KMOD_template,LOOP,loop,\
index c24de60..9475620 100644 (file)
@@ -297,6 +297,14 @@ FILES=$(MODULES_DIR)/kernel/net/ipv4/ip_gre.$(LINUX_KMOD_SUFFIX)
 endef
 $(eval $(call KernelPackage,gre))
 
+define KernelPackage/tun
+TITLE:=Universal TUN/TAP driver
+DESCRIPTION:=Kernel support for the TUN/TAP tunneling device
+KCONFIG:=$(CONFIG_TUN)
+FILES:=$(MODULES_DIR)/kernel/drivers/net/tun.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,tun))
+
 define KernelPackage/ppp
 TITLE:=PPP modules
 DESCRIPTION:=Kernel modules for PPP support
index f9c72c0..9b505df 100644 (file)
@@ -16,13 +16,6 @@ config PACKAGE_KMOD_ATM
        help
          ATM support
 
-config PACKAGE_KMOD_GRE
-       prompt "kmod-gre.......................... GRE tunneling driver"
-       tristate
-       default m
-       help
-         Kernel support for GRE tunnels
-       
 config PACKAGE_KMOD_IPIP
        prompt "kmod-ipip......................... IP in IP encapsulation support"
        tristate