image.mk: make image too big warnings more visible
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 May 2015 08:27:55 +0000 (08:27 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 May 2015 08:27:55 +0000 (08:27 +0000)
Output warnings through stderr to allow them to be easilier spotted
when building with V=w.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45746 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 921d78d..f6f30c5 100644 (file)
@@ -321,7 +321,7 @@ endef
 
 define Build/check-size
        @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -gt "$$(stat -c%s $@)" ] || { \
-               echo "WARNING: Image file $@ is too big"; \
+               echo "WARNING: Image file $@ is too big" >&2; \
                rm -f $@; \
        }
 endef
@@ -378,7 +378,7 @@ endif
 
 define Device/Build/check_size
        @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -gt "$$(stat -c%s $@)" ] || { \
-               echo "WARNING: Image file $@ is too big"; \
+               echo "WARNING: Image file $@ is too big" >&2; \
                rm -f $@; \
        }
 endef