ramips: raeth: add missing Kconfig and Makefile
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Feb 2012 09:44:30 +0000 (09:44 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Feb 2012 09:44:30 +0000 (09:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30671 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/files/drivers/net/ethernet/ramips/Kconfig [new file with mode: 0644]
target/linux/ramips/files/drivers/net/ethernet/ramips/Makefile [new file with mode: 0644]

diff --git a/target/linux/ramips/files/drivers/net/ethernet/ramips/Kconfig b/target/linux/ramips/files/drivers/net/ethernet/ramips/Kconfig
new file mode 100644 (file)
index 0000000..08d7ad1
--- /dev/null
@@ -0,0 +1,13 @@
+config NET_RAMIPS
+       tristate "Ralink RT288X/RT3X5X/RT3662/RT3883 ethernet driver"
+       depends on MIPS_RALINK
+       select PHYLIB if (SOC_RT288X || SOC_RT3883)
+       help
+         This driver supports the etehrnet mac inside the ralink wisocs
+
+if NET_RAMIPS
+
+config NET_RAMIPS_DEBUG
+       bool "Enable debug messages in the Ralink ethernet driver"
+
+endif
diff --git a/target/linux/ramips/files/drivers/net/ethernet/ramips/Makefile b/target/linux/ramips/files/drivers/net/ethernet/ramips/Makefile
new file mode 100644 (file)
index 0000000..db4a58f
--- /dev/null
@@ -0,0 +1,5 @@
+#
+# Makefile for the Ramips SoCs built-in ethernet macs
+#
+
+obj-$(CONFIG_NET_RAMIPS)       += ramips.o