[package] uhttpd:
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 24 Apr 2010 11:07:41 +0000 (11:07 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 24 Apr 2010 11:07:41 +0000 (11:07 +0000)
- ignore authentication realms that refer to user accounts with no password set yet (X-Wrt compatibility)
- fix off-by-one in CGI header parsing, fixes cgi programs that emit bad header lines (AsteriskGUI compatibility)
- bump version

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21121 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uhttpd/Makefile
package/uhttpd/src/uhttpd-cgi.c
package/uhttpd/src/uhttpd-utils.c
package/uhttpd/src/uhttpd.c

index 0f267be..0dcc6a9 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 1a6c6ad..855a72f 100644 (file)
@@ -68,7 +68,7 @@ static struct http_response * uh_cgi_header_parse(char *buf, int len, int *off)
                                if( (pos < len) && (buf[pos] == '\n') )
                                        pos++;
 
-                               if( pos < len )
+                               if( pos <= len )
                                {
                                        if( (hdrcount + 1) < array_size(res.headers) )
                                        {
index 96c0b82..caa6b12 100644 (file)
@@ -622,10 +622,14 @@ struct auth_realm * uh_auth_add(char *path, char *user, char *pass)
                                min(strlen(pass), sizeof(new->pass) - 1));
                }
 
-               uh_realm_count++;
+               if( new->pass[0] )
+               {
+                       uh_realm_count++;
+                       return new;
+               }
        }
 
-       return new;
+       return NULL;
 }
 
 int uh_auth_check(
index 9de77c8..152e0b4 100644 (file)
@@ -71,8 +71,8 @@ static void uh_config_parse(const char *path)
                                if( !uh_auth_add(line, user, pass) )
                                {
                                        fprintf(stderr,
-                                               "Can not manage more than %i basic auth realms, "
-                                               "will skip the rest\n", UH_LIMIT_AUTHREALMS
+                                               "Notice: No password set for user %s, ignoring "
+                                               "authentication on %s\n", user, line
                                        );
 
                                        break;