mac80211: fix a typo in the mac80211.sh
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Nov 2009 21:21:28 +0000 (21:21 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Nov 2009 21:21:28 +0000 (21:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18567 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile
package/mac80211/files/lib/wifi/mac80211.sh

index 6fb2b23..9440ca6 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=2009-11-21
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_SOURCE_URL:= \
        http://www.orbit-lab.org/kernel/compat-wireless-2.6/2009/11 \
        http://wireless.kernel.org/download/compat-wireless-2.6
index 591d978..b7984a3 100644 (file)
@@ -309,7 +309,7 @@ detect_mac80211() {
                [ "$ht_cap" -gt 0 ] && {
                        mode_11n="n"
                        list="  list ht_capab"
-                       [ "$(($ht_cap & 2))" -eq 1 ] && append ht_capab "$list  LDPC" "$N"
+                       [ "$(($ht_cap & 1))" -eq 1 ] && append ht_capab "$list  LDPC" "$N"
                        [ "$(($ht_cap & 2))" -eq 2 ] && append ht_capab "$list  HT40-" "$N"
                        [ "$(($ht_cap & 32))" -eq 32 ] && append ht_capab "$list        SHORT-GI-20" "$N"
                        [ "$(($ht_cap & 64))" -eq 64 ] && append ht_capab "$list        SHORT-GI-40" "$N"