target features: fix usb support detection
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Sep 2008 11:33:00 +0000 (11:33 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Sep 2008 11:33:00 +0000 (11:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12551 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk

index 357bb1f..559f8dd 100644 (file)
@@ -133,7 +133,7 @@ ifeq ($(DUMP),1)
     ifneq ($(CONFIG_PCI),)
       FEATURES += pci
     endif
-    ifneq ($(CONFIG_USB),)
+    ifneq ($(CONFIG_USB)$(CONFIG_USB_SUPPORT),)
       FEATURES += usb
     endif
     ifneq ($(CONFIG_PCMCIA)$(CONFIG_PCCARD),)