gcc: update 4.9 to linaro 2014.10
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 20 Oct 2014 11:42:59 +0000 (11:42 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 20 Oct 2014 11:42:59 +0000 (11:42 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43003 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/common.mk
toolchain/gcc/patches/4.9-linaro/020-fix_pr61144.patch [deleted file]
toolchain/gcc/patches/4.9-linaro/203-musl_powerpc.patch
toolchain/gcc/patches/4.9-linaro/910-mbsd_multi.patch

index 4ee344f..925964e 100644 (file)
@@ -42,11 +42,11 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
       PKG_COMP:=xz
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.9-linaro")
-      LINARO_RELEASE:=14.09
-      PKG_REV:=4.9-2014.09
+      LINARO_RELEASE:=14.10
+      PKG_REV:=4.9-2014.10
       PKG_VERSION:=4.9.2
       PKG_VERSION_MAJOR:=4.9
-      PKG_MD5SUM:=ac920b5800623ff99137d3cf23ad09ca
+      PKG_MD5SUM:=230da25b1e7661a8659eb770c5c88442
       PKG_COMP:=xz
     endif
     ifneq ($(LINARO_RELEASE),)
diff --git a/toolchain/gcc/patches/4.9-linaro/020-fix_pr61144.patch b/toolchain/gcc/patches/4.9-linaro/020-fix_pr61144.patch
deleted file mode 100644 (file)
index a6b320d..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/gcc/varpool.c
-+++ b/gcc/varpool.c
-@@ -329,8 +329,16 @@ ctor_for_folding (tree decl)
-   /* Variables declared 'const' without an initializer
-      have zero as the initializer if they may not be
--     overridden at link or run time.  */
--  if (!DECL_INITIAL (real_decl)
-+     overridden at link or run time.
-+
-+     It is actually requirement for C++ compiler to optimize const variables
-+     consistently. As a GNU extension, do not enfore this rule for user defined
-+     weak variables, so we support interposition on:
-+     static const int dummy = 0;
-+     extern const int foo __attribute__((__weak__, __alias__("dummy"))); 
-+   */
-+  if ((!DECL_INITIAL (real_decl)
-+       || (DECL_WEAK (decl) && !DECL_COMDAT (decl)))
-       && (DECL_EXTERNAL (decl) || decl_replaceable_p (decl)))
-     return error_mark_node;
index d8150f2..93087bb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config.gcc
 +++ b/gcc/config.gcc
-@@ -2328,6 +2328,10 @@ powerpc*-*-linux*)
+@@ -2334,6 +2334,10 @@ powerpc*-*-linux*)
            powerpc*-*-linux*paired*)
                tm_file="${tm_file} rs6000/750cl.h" ;;
        esac
index b150a43..f14f085 100644 (file)
  -Wfatal-errors  -Wfloat-equal  -Wformat  -Wformat=2 @gol
  -Wno-format-contains-nul -Wno-format-extra-args -Wformat-nonliteral @gol
  -Wformat-security  -Wformat-y2k @gol
-@@ -5041,6 +5041,22 @@ This option is only supported for C and 
+@@ -5042,6 +5042,22 @@ This option is only supported for C and 
  @option{-Wall} and by @option{-Wpedantic}, which can be disabled with
  @option{-Wno-pointer-sign}.
  
  @item -Wstack-protector
  @opindex Wstack-protector
  @opindex Wno-stack-protector
-@@ -7188,7 +7204,7 @@ so, the first branch is redirected to ei
+@@ -7189,7 +7205,7 @@ so, the first branch is redirected to ei
  second branch or a point immediately following it, depending on whether
  the condition is known to be true or false.