hostapd: automatically add wds sta interfaces of an ap to the right bridge
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Nov 2009 05:15:55 +0000 (05:15 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Nov 2009 05:15:55 +0000 (05:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18365 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostapd/Makefile
package/hostapd/files/hostapd.hotplug [new file with mode: 0644]

index 606ec67..a39b0e2 100644 (file)
@@ -109,6 +109,8 @@ define Build/Compile
 endef
 
 define Package/InstallTemplate
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/net
+       $(INSTALL_DATA) ./files/hostapd.hotplug $(1)/etc/hotplug.d/net/
        $(INSTALL_DIR) $(1)/lib/wifi
        $(INSTALL_DATA) ./files/hostapd.sh $(1)/lib/wifi/hostapd.sh
        $(INSTALL_DIR) $(1)/usr/sbin
diff --git a/package/hostapd/files/hostapd.hotplug b/package/hostapd/files/hostapd.hotplug
new file mode 100644 (file)
index 0000000..2964224
--- /dev/null
@@ -0,0 +1,12 @@
+if [ "$ACTION" = "add" -o "$ACTION" = "register" ]; then
+       case "$INTERFACE" in
+               wlan*.sta*)
+                       local BASEIF="${INTERFACE%%\.*}"
+
+                       include /lib/network
+                       scan_interfaces
+                       local CONFIG="$(find_config "$BASEIF")" 
+                       [ -n "$CONFIG" ] && setup_interface "$INTERFACE" "$CONFIG"
+               ;;
+       esac
+fi