dnsmasq: add directory for external hosts-files
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 May 2013 14:44:12 +0000 (14:44 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 17 May 2013 14:44:12 +0000 (14:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36655 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/files/dnsmasq.init

index 5ad32f2..467c934 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.66
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 62adb26..cc5ff7d 100644 (file)
@@ -134,6 +134,9 @@ dnsmasq() {
        config_get hostsfile "$cfg" dhcphostsfile
        [ -e "$hostsfile" ] && xappend "--dhcp-hostsfile=$hostsfile"
 
+       mkdir -p /tmp/hosts
+       xappend "--addn-hosts=/tmp/hosts"
+
        local rebind
        config_get_bool rebind "$cfg" rebind_protection 1
        [ $rebind -gt 0 ] && {