[kernel] update 2.6.35.x to 2.6.35.7
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Oct 2010 07:42:32 +0000 (07:42 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 Oct 2010 07:42:32 +0000 (07:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23213 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/brcm63xx/Makefile
target/linux/kirkwood/Makefile
target/linux/malta/Makefile
target/linux/xburst/Makefile
target/linux/xburst/patches-2.6.35/054-mmc.patch

index e24ce33..ed68cfd 100644 (file)
@@ -20,8 +20,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.34.5)
   LINUX_KERNEL_MD5SUM:=d280b596b32f7497bbe9dd54669c99d6
 endif
-ifeq ($(LINUX_VERSION),2.6.35.4)
-  LINUX_KERNEL_MD5SUM:=0bb2cd59c13d7412f813c8fbc0769eec
+ifeq ($(LINUX_VERSION),2.6.35.7)
+  LINUX_KERNEL_MD5SUM:=f741879bcd3a5366a1bbe0ad5cdb7935
 endif
 
 # disable the md5sum check for unknown kernel versions
index c785d26..9873db3 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.35.4
+LINUX_VERSION:=2.6.35.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 99e8957..67312b8 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
 FEATURES:=targz usb jffs2
 
-LINUX_VERSION:=2.6.35.4
+LINUX_VERSION:=2.6.35.7
 
 include $(INCLUDE_DIR)/target.mk
 
index c7b5f86..5464833 100644 (file)
@@ -12,7 +12,7 @@ CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 
-LINUX_VERSION:=2.6.35.4
+LINUX_VERSION:=2.6.35.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 3bb255f..d732bf5 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=2.6.35.4
+LINUX_VERSION:=2.6.35.7
 
 DEVICE_TYPE=other
 
index 74ab973..1a07655 100644 (file)
@@ -21,9 +21,6 @@ Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
  create mode 100644 arch/mips/include/asm/mach-jz4740/jz4740_mmc.h
  create mode 100644 drivers/mmc/host/jz4740_mmc.c
 
-diff --git a/arch/mips/include/asm/mach-jz4740/jz4740_mmc.h b/arch/mips/include/asm/mach-jz4740/jz4740_mmc.h
-new file mode 100644
-index 0000000..8543f43
 --- /dev/null
 +++ b/arch/mips/include/asm/mach-jz4740/jz4740_mmc.h
 @@ -0,0 +1,15 @@
@@ -42,11 +39,9 @@ index 0000000..8543f43
 +};
 +
 +#endif
-diff --git a/drivers/mmc/host/Kconfig b/drivers/mmc/host/Kconfig
-index f06d06e..d25e22c 100644
 --- a/drivers/mmc/host/Kconfig
 +++ b/drivers/mmc/host/Kconfig
-@@ -432,3 +432,12 @@ config MMC_SH_MMCIF
+@@ -457,3 +457,12 @@ config MMC_SH_MMCIF
          This selects the MMC Host Interface controler (MMCIF).
  
          This driver supports MMCIF in sh7724/sh7757/sh7372.
@@ -59,21 +54,16 @@ index f06d06e..d25e22c 100644
 +        SoCs.
 +        If you have a board based on such a SoC and with a SD/MMC slot,
 +        say Y or M here.
-diff --git a/drivers/mmc/host/Makefile b/drivers/mmc/host/Makefile
-index e30c2ee..f4e53c9 100644
 --- a/drivers/mmc/host/Makefile
 +++ b/drivers/mmc/host/Makefile
-@@ -36,6 +36,7 @@ obj-$(CONFIG_MMC_CB710)      += cb710-mmc.o
- obj-$(CONFIG_MMC_VIA_SDMMC)   += via-sdmmc.o
+@@ -37,6 +37,7 @@ obj-$(CONFIG_MMC_VIA_SDMMC)  += via-sdmmc
+ obj-$(CONFIG_GPIOMMC)         += gpiommc.o
  obj-$(CONFIG_SDH_BFIN)                += bfin_sdh.o
  obj-$(CONFIG_MMC_SH_MMCIF)    += sh_mmcif.o
 +obj-$(CONFIG_MMC_JZ4740)      += jz4740_mmc.o
  
  obj-$(CONFIG_MMC_SDHCI_OF)    += sdhci-of.o
  sdhci-of-y                            := sdhci-of-core.o
-diff --git a/drivers/mmc/host/jz4740_mmc.c b/drivers/mmc/host/jz4740_mmc.c
-new file mode 100644
-index 0000000..ad4f987
 --- /dev/null
 +++ b/drivers/mmc/host/jz4740_mmc.c
 @@ -0,0 +1,1029 @@
@@ -1106,6 +1096,3 @@ index 0000000..ad4f987
 +MODULE_DESCRIPTION("JZ4740 SD/MMC controller driver");
 +MODULE_LICENSE("GPL");
 +MODULE_AUTHOR("Lars-Peter Clausen <lars@metafoo.de>");
--- 
-1.5.6.5
-