fuse: update to 2.9.0
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Jun 2012 21:06:37 +0000 (21:06 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Jun 2012 21:06:37 +0000 (21:06 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32396 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/fuse/Makefile
package/fuse/patches/112-no_break_on_mknod.patch
package/fuse/patches/300-workaround-uclibc-pthread-breakage.patch [deleted file]

index a7d4d7c..55cba6d 100644 (file)
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=fuse
-PKG_VERSION:=2.8.5
+PKG_VERSION:=2.9.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=8aa2fd689de00b73963620483084ae3b
+PKG_MD5SUM:=894ee11674f89a915ae87524aed55bc4
 
 PKG_INSTALL:=1
 
index 8536030..5f913df 100644 (file)
@@ -1,6 +1,6 @@
 --- a/util/Makefile.in
 +++ b/util/Makefile.in
-@@ -584,7 +584,7 @@ uninstall-am: uninstall-binPROGRAMS unin
+@@ -641,7 +641,7 @@ mount_util.c: $(top_srcdir)/lib/mount_ut
  
  install-exec-hook:
        -chmod u+s $(DESTDIR)$(bindir)/fusermount
diff --git a/package/fuse/patches/300-workaround-uclibc-pthread-breakage.patch b/package/fuse/patches/300-workaround-uclibc-pthread-breakage.patch
deleted file mode 100644 (file)
index a7d0c0a..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
---- a/lib/helper.c
-+++ b/lib/helper.c
-@@ -180,13 +180,41 @@ err:
- int fuse_daemonize(int foreground)
- {
-       int res;
-+      int fd;
-       if (!foreground) {
--              res = daemon(0, 0);
-+              /* uClibc daemon() has problems with pthread and friends */
-+              /* workaround from http://www.mail-archive.com/uclibc@uclibc.org/msg01073.html */
-+              /* res = daemon(0, 0); */
-+              switch (res = fork()) {
-+                      case -1:
-+                              return(-1);
-+                      case 0:
-+                              break;
-+                      default:
-+                              _exit(0);
-+              }
-+
-               if (res == -1) {
--                      perror("fuse: failed to daemonize program\n");
-+                      perror("fuse: failed to fork()\n");
-                       return -1;
-               }
-+
-+              res=setsid();
-+
-+              if (res == -1) {
-+                      perror("fuse: failed to setsid()\n");
-+              }
-+
-+              chdir("/");
-+
-+              if (fd = open("/dev/null", O_RDWR, 0) != -1) {
-+                      dup2(fd, STDIN_FILENO);
-+                      dup2(fd, STDOUT_FILENO);
-+                      dup2(fd, STDERR_FILENO);
-+                      if (fd > 2)
-+                              close(fd);
-+              }
-       }
-       return 0;
- }