[brcm63xx] Profiles: Move wpad-mini to the profiles that use it, rather than default...
authorcshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Dec 2010 00:40:24 +0000 (00:40 +0000)
committercshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Dec 2010 00:40:24 +0000 (00:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24314 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/Makefile
target/linux/brcm63xx/profiles/100-Broadcom.mk
target/linux/brcm63xx/profiles/101-Broadcom-wl.mk
target/linux/brcm63xx/profiles/102-Atheros.mk
target/linux/brcm63xx/profiles/103-Ralink.mk

index 5bdc103..9b90432 100644 (file)
@@ -14,7 +14,7 @@ LINUX_VERSION:=2.6.35.9
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-switch gpioctl
+DEFAULT_PACKAGES += kmod-switch gpioctl
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
index b7e1f46..bc68f14 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom
   NAME:=Broadcom WiFi (default)
-  PACKAGES:=kmod-b43
+  PACKAGES:=kmod-b43 wpad-mini
 endef
 
 define Profile/Broadcom/Description
index d67298c..4f2d605 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom-wl
   NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
-  PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas
+  PACKAGES:= kmod-brcm-wl wlc nas
 endef
 
 define Profile/Broadcom-wl/Description
index 0295868..c6d2da6 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Atheros
   NAME:=Atheros WiFi (default)
-  PACKAGES:=kmod-madwifi
+  PACKAGES:=kmod-madwifi wpad-mini
 endef
 
 define Profile/Atheros/Description
index 0d78ae4..412c5a4 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Ralink
   NAME:=Ralink WiFi
-  PACKAGES:=kmod-rt61-pci
+  PACKAGES:=kmod-rt61-pci wpad-mini
 endef
 $(eval $(call Profile,Ralink))