[include] autotools.mk: if ./autogen.sh exists, call that. Call autoreconfig only...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Dec 2010 01:15:38 +0000 (01:15 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 8 Dec 2010 01:15:38 +0000 (01:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24319 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/autotools.mk

index a2d57d6..3203604 100644 (file)
@@ -23,7 +23,14 @@ define libtool_remove_files
 endef
 
 define autoreconf
-       (cd $(PKG_BUILD_DIR); $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS));
+       (cd $(PKG_BUILD_DIR); \
+               if [ -x ./autogen.sh ]; then \
+                       ./autogen.sh; \
+               elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
+                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS); \
+               fi \
+       );
 endef
 
 Hooks/InstallDev/Post += libtool_remove_files