[kirkwood] Add kernel package for the mv_cesa crypto module
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 3 Sep 2010 01:03:22 +0000 (01:03 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 3 Sep 2010 01:03:22 +0000 (01:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22877 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/kirkwood/modules.mk [new file with mode: 0644]

diff --git a/target/linux/kirkwood/modules.mk b/target/linux/kirkwood/modules.mk
new file mode 100644 (file)
index 0000000..ed7fe88
--- /dev/null
@@ -0,0 +1,11 @@
+
+define KernelPackage/crypto-mv_cesa
+   TITLE:=Marvell crypto engine
+   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
+   FILES:=$(LINUX_DIR)/crypto/mv_cesa.ko
+   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
+   SUBMENU:=Cryptographic API modules
+   DEPENDS:=kmod-crypto-core
+endef
+
+$(eval $(call KernelPackage,crypto-mv_cesa))