Added new modules, modularize them
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 18 Mar 2006 22:15:33 +0000 (22:15 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 18 Mar 2006 22:15:33 +0000 (22:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3405 3c298f89-4303-0410-b956-a3cf2f4a3e73

24 files changed:
openwrt/package/openser/Config.in
openwrt/package/openser/Makefile
openwrt/package/openser/ipkg/openser-mod-avp-radius.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-avp_radius.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-dispatcher.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-diversion.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-flatstore.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-gflags.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-group-radius.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-group.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-group_radius.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-msilo.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-options.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-pdt.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-permissions.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-pike.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uac-redirect.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uac.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uac_redirect.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uri-db.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uri-radius.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uri.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uri_db.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uri_radius.control [new file with mode: 0644]

index d015c07..b7580a6 100644 (file)
@@ -1,24 +1,15 @@
-menu "openser............................ Configurable, free SIP server"
+menu "openser........................... Configurable, free SIP server"
 
 config BR2_PACKAGE_OPENSER
-       tristate 
-       prompt "openser.......................... Configurable, free SIP server"
+       prompt "openser........................... Configurable, free SIP server"
+       tristate
        default m if CONFIG_DEVEL
        help
         Open SIP Express Router (OpenSER) is a high-performance,
         configurable, free SIP server.
 
-config BR2_PACKAGE_OPENSER_MOD_MYSQL
-       prompt "openser-mod-mysql................ MySQL support"
-       tristate        
-       default m
-       select BR2_COMPILE_MYSQL
-       select BR2_PACKAGE_OPENSER
-       help
-         Enable MySQL support
-
 config BR2_PACKAGE_OPENSER_MOD_AUTH
-       prompt "openser-mod-auth................. Authentication support"
+       prompt "openser-mod-auth.................. Authentication support"
        tristate
        default m
        select BR2_PACKAGE_OPENSER
@@ -26,7 +17,7 @@ config BR2_PACKAGE_OPENSER_MOD_AUTH
          Enable authentication support
 
 config BR2_PACKAGE_OPENSER_MOD_AUTH_DB
-       prompt "openser-mod-auth-db.............. Authentication with database support"
+       prompt "openser-mod-auth-db............... Authentication with database support"
        tristate
        default m
        select BR2_PACKAGE_OPENSER
@@ -35,7 +26,7 @@ config BR2_PACKAGE_OPENSER_MOD_AUTH_DB
          Enable authentication with database support
 
 config BR2_PACKAGE_OPENSER_MOD_AUTH_RADIUS
-       prompt "openser-mod-auth-radius.......... Authentication with RADIUS support"
+       prompt "openser-mod-auth-radius........... Authentication with RADIUS support"
        tristate
        default m
        select BR2_PACKAGE_OPENSER
@@ -43,42 +34,147 @@ config BR2_PACKAGE_OPENSER_MOD_AUTH_RADIUS
        help
          Authentication against RADIUS
 
+config BR2_PACKAGE_OPENSER_MOD_AVP_RADIUS
+        prompt "openser-mod-avp-radius............ AVP with RADIUS support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+       select BR2_PACKAGE_LIBRADIUSCLIENT_NG
+        help
+          Enable AVP with RADIUS support
+
 config BR2_PACKAGE_OPENSER_MOD_AVPOPS
-       prompt "openser-mod-avpops............... AVP options support"
+       prompt "openser-mod-avpops................ AVP options support"
        tristate
        default m
        select BR2_PACKAGE_OPENSER
        help
          Enable AVP options support
 
+config BR2_PACKAGE_OPENSER_MOD_DISPATCHER
+        prompt "openser-mod-dispatcher............ dispatcher support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable dispatcher options support
+
+config BR2_PACKAGE_OPENSER_MOD_DIVERSION
+        prompt "openser-mod-diversion............. diversion support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable diversion options support
+
+config BR2_PACKAGE_OPENSER_MOD_FLATSTORE
+        prompt "openser-mod-flatstore............. flatstore support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable flatstore support
+
+config BR2_PACKAGE_OPENSER_MOD_GFLAGS
+        prompt "openser-mod-gflags................ gflags support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable GFlags support
+
+config BR2_PACKAGE_OPENSER_MOD_GROUP
+        prompt "openser-mod-group................. group support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable group support
+
+config BR2_PACKAGE_OPENSER_MOD_GROUP_RADIUS
+        prompt "openser-mod-group-radius.......... group with RADIUS support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable group with RADIUS support
+
+config BR2_PACKAGE_OPENSER_MOD_LCR
+        prompt "openser-mod-lcr................... Least Cost Routing support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        select BR2_PACKAGE_OPENSER_MOD_MYSQL
+        help
+          Enable Least Cost Routing support
 
 config BR2_PACKAGE_OPENSER_MOD_MEDIAPROXY
-       prompt "openser-mod-mediaproxy........... Mediaproxy support"
+       prompt "openser-mod-mediaproxy............ Mediaproxy support"
        tristate
        default m
        select BR2_PACKAGE_OPENSER
        help
          Enable mediaproxy support
 
-config BR2_PACKAGE_OPENSER_MOD_LCR
-       prompt "openser-mod-lcr.................. Least Cost Routing support"
+config BR2_PACKAGE_OPENSER_MOD_MSILO
+        prompt "openser-mod-msilo................. MSilo support"
        tristate
-       default m
-       select BR2_PACKAGE_OPENSER
-       select BR2_PACKAGE_OPENSER_MOD_MYSQL
-       help
-         Enable Least Cost Routing support
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable msilo support
+
+config BR2_PACKAGE_OPENSER_MOD_MYSQL
+        prompt "openser-mod-mysql................. MySQL support"
+       tristate
+        default m
+        select BR2_PACKAGE_LIBMYSQLCLIENT
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable MySQL support
 
 config BR2_PACKAGE_OPENSER_MOD_NATHELPER
-       prompt "openser-mod-nathelper............ NAT helper support"
+       prompt "openser-mod-nathelper............. NAT helper support"
        tristate
        default m
        select BR2_PACKAGE_OPENSER
        help
          NAT helper support
 
+config BR2_PACKAGE_OPENSER_MOD_OPTIONS
+        prompt "openser-mod-options............... options support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable options support
+
+config BR2_PACKAGE_OPENSER_MOD_PDT
+        prompt "openser-mod-pdt................... PDT support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable pdt support
+
+config BR2_PACKAGE_OPENSER_MOD_PERMISSIONS
+        prompt "openser-mod-permissions........... Permissions support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable permissions support
+
+config BR2_PACKAGE_OPENSER_MOD_PIKE
+        prompt "openser-mod-pike.................. PIKE support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable pike support
+
 config BR2_PACKAGE_OPENSER_MOD_SMS
-       prompt "openser-mod-sms.................. SMS support"
+       prompt "openser-mod-sms................... SMS support"
        tristate
        default m
        select BR2_PACKAGE_OPENSER
@@ -86,15 +182,55 @@ config BR2_PACKAGE_OPENSER_MOD_SMS
          SMS support
 
 config BR2_PACKAGE_OPENSER_MOD_SPEEDDIAL
-       prompt "openser-mod-speeddial............ Speed dial support"
+       prompt "openser-mod-speeddial............. Speed Dial support"
        tristate
        default m
        select BR2_PACKAGE_OPENSER
        help
          Speed Dial support
 
+config BR2_PACKAGE_OPENSER_MOD_UAC
+        prompt "openser-mod-uac................... UAC support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable UAC support
+
+config BR2_PACKAGE_OPENSER_MOD_UAC_REDIRECT
+        prompt "openser-mod-uac................... UAC redirect support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable UAC redirect support
+
+config BR2_PACKAGE_OPENSER_MOD_URI
+        prompt "openser-mod-uri................... URI support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable URI support
+
+config BR2_PACKAGE_OPENSER_MOD_URI_DB
+        prompt "openser-mod-uri-db................ URI database support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable URI database support
+
+config BR2_PACKAGE_OPENSER_MOD_URI_RADIUS
+        prompt "openser-mod-uri-radius............ URI with RADIUS support"
+       tristate
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable URI with RADIUS support
+
 config BR2_PACKAGE_OPENSER_MOD_XLOG
-       prompt "openser-mod-xlog................. Logging support"
+       prompt "openser-mod-xlog.................. Logging support"
        tristate
        default m
        select BR2_PACKAGE_OPENSER
index 40c0039..7ea52d1 100644 (file)
@@ -34,26 +34,60 @@ $(eval $(call PKG_template,OPENSER_MOD_ACCOUNTING,openser-mod-acc,$(PKG_VERSION)
 $(eval $(call PKG_template,OPENSER_MOD_AUTH,openser-mod-auth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_AUTH_DB,openser-mod-auth-db,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_AUTH_RADIUS,openser-mod-auth-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_AVP_RADIUS,openser-mod-avp-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_AVPOPS,openser-mod-avpops,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_DISPATCHER,openser-mod-dispatcher,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_DIVERSION,openser-mod-diversion,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_FLATSTORE,openser-mod-flatstore,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_GFLAGS,openser-mod-gflags,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_GROUP,openser-mod-group,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_GROUP_RADIUS,openser-mod-group-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_LCR,openser-mod-lcr,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_MEDIAPROXY,openser-mod-mediaproxy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_MSILO,openser-mod-msilo,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_MYSQL,openser-mod-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_NATHELPER,openser-mod-nathelper,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_OPTIONS,openser-mod-options,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_PDT,openser-mod-pdt,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_PERMISSIONS,openser-mod-permissions,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_PIKE,openser-mod-pike,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_SMS,openser-mod-sms,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,OPENSER_MOD_SPEEDDIAL,openser-mod-speeddial,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_UAC,openser-mod-uac,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_UAC_REDIRECT,openser-mod-uac-redirect,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_URI,openser-mod-uri,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_URI_DB,openser-mod-uri-db,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_URI_RADIUS,openser-mod-uri-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_AUTH_RADIUS,openser-mod-auth-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_XLOG,openser-mod-xlog,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(eval $(call PKG_mod_template,OPENSER_MOD_ACCOUNTING,acc))
 $(eval $(call PKG_mod_template,OPENSER_MOD_AUTH,auth))
 $(eval $(call PKG_mod_template,OPENSER_MOD_AUTH_DB,auth_db))
 $(eval $(call PKG_mod_template,OPENSER_MOD_AUTH_RADIUS,auth_radius))
+$(eval $(call PKG_mod_template,OPENSER_MOD_AVP_RADIUS,avp_radius))
 $(eval $(call PKG_mod_template,OPENSER_MOD_AVPOPS,avpops))
+$(eval $(call PKG_mod_template,OPENSER_MOD_DISPATCHER,dispatcher))
+$(eval $(call PKG_mod_template,OPENSER_MOD_DIVERSION,diversion))
+$(eval $(call PKG_mod_template,OPENSER_MOD_FLATSTORE,flatstore))
+$(eval $(call PKG_mod_template,OPENSER_MOD_GFLAGS,gflags))
+$(eval $(call PKG_mod_template,OPENSER_MOD_GROUP,group))
+$(eval $(call PKG_mod_template,OPENSER_MOD_GROUP_RADIUS,group_radius))
 $(eval $(call PKG_mod_template,OPENSER_MOD_LCR,lcr))
 $(eval $(call PKG_mod_template,OPENSER_MOD_MEDIAPROXY,mediaproxy))
+$(eval $(call PKG_mod_template,OPENSER_MOD_MSILO,msilo))
 $(eval $(call PKG_mod_template,OPENSER_MOD_MYSQL,mysql))
 $(eval $(call PKG_mod_template,OPENSER_MOD_NATHELPER,nathelper))
+$(eval $(call PKG_mod_template,OPENSER_MOD_OPTIONS,options))
+$(eval $(call PKG_mod_template,OPENSER_MOD_PDT,pdt))
+$(eval $(call PKG_mod_template,OPENSER_MOD_PERMISSIONS,permissions))
+$(eval $(call PKG_mod_template,OPENSER_MOD_PIKE,pike))
 $(eval $(call PKG_mod_template,OPENSER_MOD_SMS,sms))
 $(eval $(call PKG_mod_template,OPENSER_MOD_SPEEDIAL,speeddial))
+$(eval $(call PKG_mod_template,OPENSER_MOD_UAC,uac))
+$(eval $(call PKG_mod_template,OPENSER_MOD_UAC_REDIRECT,uac_redirect))
+$(eval $(call PKG_mod_template,OPENSER_MOD_URI,uri))
+$(eval $(call PKG_mod_template,OPENSER_MOD_URI_DB,uri_db))
+$(eval $(call PKG_mod_template,OPENSER_MOD_URI_RADIUS,uri_radius))
 $(eval $(call PKG_mod_template,OPENSER_MOD_XLOG,xlog))
 
 # Select here the modules for the ipk package
diff --git a/openwrt/package/openser/ipkg/openser-mod-avp-radius.control b/openwrt/package/openser/ipkg/openser-mod-avp-radius.control
new file mode 100644 (file)
index 0000000..1f09797
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-avp-radius
+Depends: openser
+Section: net
+Priority: optional
+Description: avp_radius support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-avp_radius.control b/openwrt/package/openser/ipkg/openser-mod-avp_radius.control
new file mode 100644 (file)
index 0000000..5736697
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-avp_radius
+Depends: openser
+Section: net
+Priority: optional
+Description: avp_radius support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-dispatcher.control b/openwrt/package/openser/ipkg/openser-mod-dispatcher.control
new file mode 100644 (file)
index 0000000..eabfd6d
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-dispatcher
+Depends: openser
+Section: net
+Priority: optional
+Description: dispatcher support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-diversion.control b/openwrt/package/openser/ipkg/openser-mod-diversion.control
new file mode 100644 (file)
index 0000000..bcf4011
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-diversion
+Depends: openser
+Section: net
+Priority: optional
+Description: diversion support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-flatstore.control b/openwrt/package/openser/ipkg/openser-mod-flatstore.control
new file mode 100644 (file)
index 0000000..96e0835
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-flatstore
+Depends: openser
+Section: net
+Priority: optional
+Description: flatstore support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-gflags.control b/openwrt/package/openser/ipkg/openser-mod-gflags.control
new file mode 100644 (file)
index 0000000..ce99494
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-gflags
+Depends: openser
+Section: net
+Priority: optional
+Description: gflags support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-group-radius.control b/openwrt/package/openser/ipkg/openser-mod-group-radius.control
new file mode 100644 (file)
index 0000000..bb5fbed
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-group-radius
+Depends: openser
+Section: net
+Priority: optional
+Description: group_radius support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-group.control b/openwrt/package/openser/ipkg/openser-mod-group.control
new file mode 100644 (file)
index 0000000..b7c1130
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-group
+Depends: openser
+Section: net
+Priority: optional
+Description: group support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-group_radius.control b/openwrt/package/openser/ipkg/openser-mod-group_radius.control
new file mode 100644 (file)
index 0000000..bf47826
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-group_radius
+Depends: openser
+Section: net
+Priority: optional
+Description: group_radius support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-msilo.control b/openwrt/package/openser/ipkg/openser-mod-msilo.control
new file mode 100644 (file)
index 0000000..215701e
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-msilo
+Depends: openser
+Section: net
+Priority: optional
+Description: msilo support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-options.control b/openwrt/package/openser/ipkg/openser-mod-options.control
new file mode 100644 (file)
index 0000000..b94da0b
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-options
+Depends: openser
+Section: net
+Priority: optional
+Description: options support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-pdt.control b/openwrt/package/openser/ipkg/openser-mod-pdt.control
new file mode 100644 (file)
index 0000000..9539291
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-pdt
+Depends: openser
+Section: net
+Priority: optional
+Description: pdt support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-permissions.control b/openwrt/package/openser/ipkg/openser-mod-permissions.control
new file mode 100644 (file)
index 0000000..302abdb
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-permissions
+Depends: openser
+Section: net
+Priority: optional
+Description: permissions support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-pike.control b/openwrt/package/openser/ipkg/openser-mod-pike.control
new file mode 100644 (file)
index 0000000..c8a2111
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-pike
+Depends: openser
+Section: net
+Priority: optional
+Description: pike support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uac-redirect.control b/openwrt/package/openser/ipkg/openser-mod-uac-redirect.control
new file mode 100644 (file)
index 0000000..9a4785f
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uac-redirect
+Depends: openser
+Section: net
+Priority: optional
+Description: uac_redirect support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uac.control b/openwrt/package/openser/ipkg/openser-mod-uac.control
new file mode 100644 (file)
index 0000000..957bbaa
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uac
+Depends: openser
+Section: net
+Priority: optional
+Description: uac support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uac_redirect.control b/openwrt/package/openser/ipkg/openser-mod-uac_redirect.control
new file mode 100644 (file)
index 0000000..1eb0569
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uac_redirect
+Depends: openser
+Section: net
+Priority: optional
+Description: uac_redirect support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uri-db.control b/openwrt/package/openser/ipkg/openser-mod-uri-db.control
new file mode 100644 (file)
index 0000000..a48560b
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uri-db
+Depends: openser
+Section: net
+Priority: optional
+Description: uri_db support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uri-radius.control b/openwrt/package/openser/ipkg/openser-mod-uri-radius.control
new file mode 100644 (file)
index 0000000..55f1b2a
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uri-radius
+Depends: openser
+Section: net
+Priority: optional
+Description: uri_radius support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uri.control b/openwrt/package/openser/ipkg/openser-mod-uri.control
new file mode 100644 (file)
index 0000000..ab9e33d
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uri
+Depends: openser
+Section: net
+Priority: optional
+Description: uri support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uri_db.control b/openwrt/package/openser/ipkg/openser-mod-uri_db.control
new file mode 100644 (file)
index 0000000..1fa05d1
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uri_db
+Depends: openser
+Section: net
+Priority: optional
+Description: uri_db support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uri_radius.control b/openwrt/package/openser/ipkg/openser-mod-uri_radius.control
new file mode 100644 (file)
index 0000000..070bd30
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uri_radius
+Depends: openser
+Section: net
+Priority: optional
+Description: uri_radius support for OpenSER