[PATCH] [kernel] add sata_sil24 module
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Apr 2009 15:42:16 +0000 (15:42 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Apr 2009 15:42:16 +0000 (15:42 +0000)
Signed-off-by: Erik Inge Bols? <knan-openwrt@anduin.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15261 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/block.mk

index 3c27813..ce9596e 100644 (file)
@@ -35,6 +35,22 @@ endef
 $(eval $(call KernelPackage,ata-ahci))
 
 
+define KernelPackage/ata-sil24
+  SUBMENU:=3D$(BLOCK_MENU)
+  TITLE:=3DSilicon Image 3124/3132 SATA support
+  DEPENDS:=3Dkmod-ata-core
+  KCONFIG:=3DCONFIG_SATA_SIL24
+  FILES:=3D$(LINUX_DIR)/drivers/ata/sata_sil24.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=3D$(call AutoLoad,41,sata_sil24)
+endef
+
+define KernelPackage/ata-sil24/description
+ Support for Silicon Image 3124/3132 Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sil24))
+
+
 define KernelPackage/ata-artop
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=ARTOP 6210/6260 PATA support