port iptables fix introduced by changeset:2447 to trunk
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Nov 2005 11:53:55 +0000 (11:53 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Nov 2005 11:53:55 +0000 (11:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2448 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/iptables/Makefile
target/linux/netfilter.mk

index f54481c..cdbb866 100644 (file)
@@ -75,7 +75,7 @@ $(IPKG_IPTABLES):
        cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/iptables $(IDIR_IPTABLES)/usr/sbin/
        install -d -m0755 $(IDIR_IPTABLES)/usr/lib/iptables
        (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
-               cp -fpR $(patsubst %,lib%.so,$(IPKG_IPTABLES-y) ipt_standard) $(IDIR_IPTABLES)/usr/lib/iptables/ \
+               cp -fpR $(patsubst %,lib%.so,$(IPKG_IPTABLES-y)) $(IDIR_IPTABLES)/usr/lib/iptables/ \
        )
        $(RSTRIP) $(IDIR_IPTABLES)
        $(IPKG_BUILD) $(IDIR_IPTABLES) $(PACKAGE_DIR)
index 433c386..6375a71 100644 (file)
@@ -71,7 +71,7 @@ IPKG_KMOD_IPT_ULOG-$(CONFIG_IP_NF_TARGET_ULOG) += ipt_ULOG
 #\r
 \r
 IPKG_IPTABLES-y := ipt_standard\r
-IPKG_IPTABLES-y := ipt_icmp ipt_tcp ipt_udp\r
+IPKG_IPTABLES-y += ipt_icmp ipt_tcp ipt_udp\r
 \r
 IPKG_IPTABLES_MOD_CONNTRACK-m :=\r
 IPKG_IPTABLES_MOD_CONNTRACK-$(CONFIG_IP_NF_MATCH_CONNMARK) += ipt_connmark\r