build: make mkfs-* depend on kernel installation to fix parallel build issues
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 30 Oct 2015 22:01:27 +0000 (22:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 30 Oct 2015 22:01:27 +0000 (22:01 +0000)
Reported-by: Petr Štetiar <ynezz@true.cz>
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47296 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index c59222e..4e22fa5 100644 (file)
@@ -282,7 +282,7 @@ endef
 define BuildImage/mkfs
   install: mkfs-$(1)
   .PHONY: mkfs-$(1)
-  mkfs-$(1): mkfs_prepare
+  mkfs-$(1): kernel_prepare
        $(Image/mkfs/$(1))
        $(call Build/mkfs/default,$(1))
        $(call Build/mkfs/$(1),$(1))