Added peerguardian
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Dec 2005 15:24:18 +0000 (15:24 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Dec 2005 15:24:18 +0000 (15:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2724 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/peerguardian/Config.in [new file with mode: 0755]
openwrt/package/peerguardian/Makefile [new file with mode: 0755]
openwrt/package/peerguardian/files/peerguardian.init [new file with mode: 0644]
openwrt/package/peerguardian/ipkg/peerguardian.control [new file with mode: 0644]
openwrt/package/peerguardian/patches/01-honor-libipq.patch [new file with mode: 0755]

diff --git a/openwrt/package/peerguardian/Config.in b/openwrt/package/peerguardian/Config.in
new file mode 100755 (executable)
index 0000000..564a9cc
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PEERGUARDIAN
+       prompt "peerguardian...................... PeerGuardian for Linux"
+       tristate
+       select BR2_PACKAGE_LIBPTHREAD
+       default m if CONFIG_DEVEL
+       help
+               PeerGuardian helps protect your privacy by blocking many ranges
+               of aggressive IPs while you use P2P.
+
+               http://phoenixlabs.org/
diff --git a/openwrt/package/peerguardian/Makefile b/openwrt/package/peerguardian/Makefile
new file mode 100755 (executable)
index 0000000..4504166
--- /dev/null
@@ -0,0 +1,54 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=peerguardian
+PKG_VERSION:=1.5beta
+PKG_RELEASE:=1
+PKG_MD5SUM:=0fb2bc5501b031604fc56eec3bd35fa4
+
+PKG_SOURCE_URL:=@SF/peerguardian
+PKG_SOURCE:=pglinux-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/pglinux-$(PKG_VERSION)
+PKG_CAT:=gzcat
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PEERGUARDIAN,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               --program-prefix="" \
+               --with-gnu-ld \
+       );
+       touch $@
+       
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) STAGING_DIR=$(STAGING_DIR) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR)
+       install -d -m0755 $(PKG_INSTALL_DIR)/usr/sbin $(PKG_INSTALL_DIR)/etc/init.d
+       install -m0755 $(PKG_BUILD_DIR)/peerguardnf $(PKG_INSTALL_DIR)/usr/sbin/
+       install -m0755 $(PKG_BUILD_DIR)/pgtext $(PKG_INSTALL_DIR)/usr/sbin/
+       install -m0644 $(PKG_BUILD_DIR)/PG.conf $(PKG_INSTALL_DIR)/etc/
+       install -m0644 $(PKG_BUILD_DIR)/p2p.p2b.p2p $(PKG_INSTALL_DIR)/etc/
+       install -m0644 files/$(PKG_NAME).init $(PKG_INSTALL_DIR)/etc/init.d/$(PKG_NAME)
+       
+$(IPKG_PEERGUARDIAN):
+       mkdir -p $(IDIR_PEERGUARDIAN)
+       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_PEERGUARDIAN)/
+       $(RSTRIP) $(IDIR_PEERGUARDIAN)/
+       $(IPKG_BUILD) $(IDIR_PEERGUARDIAN) $(PACKAGE_DIR)
diff --git a/openwrt/package/peerguardian/files/peerguardian.init b/openwrt/package/peerguardian/files/peerguardian.init
new file mode 100644 (file)
index 0000000..5807314
--- /dev/null
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+BIN=pgtext
+DEFAULT=/etc/default/$BIN
+[ -f $DEFAULT ] && . $DEFAULT
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN_${IF}_${ID}.pid
+
+case $1 in
+ start)
+  $BIN $OPTIONS
+  ;;
+ stop)
+  [ -f $PID_F ] && kill $(cat $PID_F) >/dev/null 2>&1
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/peerguardian/ipkg/peerguardian.control b/openwrt/package/peerguardian/ipkg/peerguardian.control
new file mode 100644 (file)
index 0000000..9c7d809
--- /dev/null
@@ -0,0 +1,6 @@
+Package: peerguardian
+Architecture: mipsel
+Section: net
+Depends: libpthread
+Description: PeerGuardian helps protect your privacy by blocking many ranges of aggressive IPs while you use P2P.
+Priority: optional
diff --git a/openwrt/package/peerguardian/patches/01-honor-libipq.patch b/openwrt/package/peerguardian/patches/01-honor-libipq.patch
new file mode 100755 (executable)
index 0000000..b58ee8a
--- /dev/null
@@ -0,0 +1,16 @@
+diff -urN pglinux-1.5beta/Makefile.in /Users/florian/dev/sdk/dl/pglinux-1.5beta/Makefile.in
+--- pglinux-1.5beta/Makefile.in        2005-03-31 09:40:29.000000000 +0200
++++ /Users/florian/dev/sdk/dl/pglinux-1.5beta/Makefile.in      2005-11-25 19:14:16.000000000 +0100
+@@ -83,10 +83,10 @@
+ PROGRAMS =  $(mybin_PROGRAMS)
+-DEFS = @DEFS@ -I. -I$(srcdir) -I.
++DEFS = @DEFS@ -I. -I$(srcdir) -I. -I$(STAGING_DIR)/usr/include
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+-LIBS = @LIBS@
++LIBS = @LIBS@ -L$(STAGING_DIR)/usr/lib
+ peerguardnf_OBJECTS =  Main.o PeerGuard.o BlockList.o Blocker_Linux.o \
+ Blocker_BSD.o HttpServer.o HttpRequest.o sha1.o
+ peerguardnf_DEPENDENCIES =