ar71xx: fix compile error in r40969, refresh patches
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 16:24:12 +0000 (16:24 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 16:24:12 +0000 (16:24 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40977 3c298f89-4303-0410-b956-a3cf2f4a3e73

21 files changed:
target/linux/ar71xx/patches-3.10/206-spi-ath79-make-chipselect-logic-more-flexible.patch
target/linux/ar71xx/patches-3.10/406-mtd-m25p80-allow-to-specify-max-read-size.patch
target/linux/ar71xx/patches-3.10/407-mtd-m25p80-allow-to-pass-probe-types-via-platform-data.patch
target/linux/ar71xx/patches-3.10/412-mtd-m25p80-zero-partition-parser-data.patch
target/linux/ar71xx/patches-3.10/424-net-phy-add-phy_mmd_read_write-functions.patch
target/linux/ar71xx/patches-3.10/521-MIPS-ath79-enable-UART-for-early_serial.patch
target/linux/ar71xx/patches-3.10/606-MIPS-ath79-pb44-fixes.patch
target/linux/ar71xx/patches-3.10/610-MIPS-ath79-openwrt-machines.patch
target/linux/ar71xx/patches-3.10/700-MIPS-ath79-add-TL-WA801NDv2-suport.patch
target/linux/ar71xx/patches-3.10/701-MIPS-ath79-add-TL-WA901ND-v3-support.patch
target/linux/ar71xx/patches-3.10/702-MIPS-ath79-add-MyNet-N750-support.patch
target/linux/ar71xx/patches-3.10/703-MIPS-ath79-add-RB91x-support.patch
target/linux/ar71xx/patches-3.10/704-MIPS-ath79-TL-WDR4900v2-support.patch
target/linux/ar71xx/patches-3.10/705-MIPS-ath79-add-RB951Ui-2HnD-support.patch
target/linux/ar71xx/patches-3.10/706-MIPS-ath79-oolite-v1-support.patch
target/linux/ar71xx/patches-3.10/708-MIPS-ath79-TL-WR841v9-support.patch
target/linux/ar71xx/patches-3.10/709-MIPS-ath79-HiWiFi-HC6361-support.patch
target/linux/ar71xx/patches-3.10/709-MIPS-ath79-add-NBG6716.patch
target/linux/ar71xx/patches-3.10/710-MIPS-ath79-add-OM2Pv2.patch
target/linux/ar71xx/patches-3.10/711-MIPS-ath79-add-OM2P-HSv2.patch
target/linux/ar71xx/patches-3.10/902-unaligned_access_hacks.patch

index b57dd5d..4f825f8 100644 (file)
@@ -170,7 +170,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  struct ath79_spi {
        struct spi_bitbang      bitbang;
        u32                     ioc_base;
-@@ -69,6 +71,7 @@ static void ath79_spi_chipselect(struct
+@@ -69,6 +71,7 @@ static void ath79_spi_chipselect(struct 
  {
        struct ath79_spi *sp = ath79_spidev_to_sp(spi);
        int cs_high = (spi->mode & SPI_CS_HIGH) ? is_active : !is_active;
@@ -178,7 +178,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
        if (is_active) {
                /* set initial clock polarity */
-@@ -80,20 +83,24 @@ static void ath79_spi_chipselect(struct
+@@ -80,20 +83,24 @@ static void ath79_spi_chipselect(struct 
                ath79_spi_wr(sp, AR71XX_SPI_REG_IOC, sp->ioc_base);
        }
  
index 8dfad61..3f9c182 100644 (file)
@@ -84,7 +84,7 @@
        mutex_unlock(&flash->lock);
  
        return 0;
-@@ -1021,6 +1044,12 @@ static int m25p_probe(struct spi_device
+@@ -1021,6 +1044,12 @@ static int m25p_probe(struct spi_device 
                flash->mtd._unlock = m25p80_unlock;
        }
  
index dd38f00..5da93a4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -1121,7 +1121,9 @@ static int m25p_probe(struct spi_device
+@@ -1121,7 +1121,9 @@ static int m25p_probe(struct spi_device 
        /* partitions should match sector boundaries; and it may be good to
         * use readonly partitions for writeprotected sectors (BP2..BP0).
         */
index abec9b5..3c987d9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -1071,6 +1071,7 @@ static int m25p_probe(struct spi_device
+@@ -1071,6 +1071,7 @@ static int m25p_probe(struct spi_device 
        if (info->flags & M25P_NO_ERASE)
                flash->mtd.flags |= MTD_NO_ERASE;
  
index 961a65b..6b69679 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/phy.c
 +++ b/drivers/net/phy/phy.c
-@@ -1009,6 +1009,12 @@ static int phy_read_mmd_indirect(struct
+@@ -1009,6 +1009,12 @@ static int phy_read_mmd_indirect(struct 
        return ret;
  }
  
index 3d6ddfe..a6e84c5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/early_printk.c
 +++ b/arch/mips/ath79/early_printk.c
-@@ -56,6 +56,46 @@ static void prom_putchar_dummy(unsigned
+@@ -56,6 +56,46 @@ static void prom_putchar_dummy(unsigned 
        /* nothing to do */
  }
  
index f9ec775..b38b461 100644 (file)
@@ -50,7 +50,7 @@
  #define PB44_GPIO_SW_RESET    (PB44_GPIO_EXP_BASE + 6)
  #define PB44_GPIO_SW_JUMP     (PB44_GPIO_EXP_BASE + 8)
  #define PB44_GPIO_LED_JUMP1   (PB44_GPIO_EXP_BASE + 9)
-@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data
+@@ -92,21 +117,66 @@ static struct ath79_spi_controller_data 
        .cs_line = 0,
  };
  
index 57e1817..2dfecd2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -16,22 +16,142 @@
+@@ -16,22 +16,143 @@
  
  enum ath79_mach_type {
        ATH79_MACH_GENERIC = 0,
index 88dc922..87c5053 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -100,6 +100,7 @@ enum ath79_mach_type {
+@@ -101,6 +101,7 @@ enum ath79_mach_type {
        ATH79_MACH_TL_WA750RE,          /* TP-LINK TL-WA750RE */
        ATH79_MACH_TL_WA7510N_V1,       /* TP-LINK TL-WA7510N v1*/
        ATH79_MACH_TL_WA850RE,          /* TP-LINK TL-WA850RE */
index 5453f70..0a9607f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -103,6 +103,7 @@ enum ath79_mach_type {
+@@ -104,6 +104,7 @@ enum ath79_mach_type {
        ATH79_MACH_TL_WA801ND_V2,       /* TP-LINK TL-WA801ND v2 */
        ATH79_MACH_TL_WA901ND,          /* TP-LINK TL-WA901ND */
        ATH79_MACH_TL_WA901ND_V2,       /* TP-LINK TL-WA901ND v2 */
index 95fb687..07b2fee 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -56,6 +56,7 @@ enum ath79_mach_type {
+@@ -57,6 +57,7 @@ enum ath79_mach_type {
        ATH79_MACH_MR600V2,             /* OpenMesh MR600v2 */
        ATH79_MACH_MR600,               /* OpenMesh MR600 */
        ATH79_MACH_MYNET_N600,          /* WD My Net N600 */
index 62204a8..f59ac82 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -75,6 +75,7 @@ enum ath79_mach_type {
+@@ -76,6 +76,7 @@ enum ath79_mach_type {
        ATH79_MACH_RB_450,              /* MikroTik RouterBOARD 450 */
        ATH79_MACH_RB_493,              /* Mikrotik RouterBOARD 493/493AH */
        ATH79_MACH_RB_493G,             /* Mikrotik RouterBOARD 493G */
index 1292b1d..848109e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -108,6 +108,7 @@ enum ath79_mach_type {
+@@ -109,6 +109,7 @@ enum ath79_mach_type {
        ATH79_MACH_TL_WA901ND_V3,       /* TP-LINK TL-WA901ND v3 */
        ATH79_MACH_TL_WDR3500,          /* TP-LINK TL-WDR3500 */
        ATH79_MACH_TL_WDR4300,          /* TP-LINK TL-WDR4300 */
index 509c947..baceacb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -81,6 +81,7 @@ enum ath79_mach_type {
+@@ -82,6 +82,7 @@ enum ath79_mach_type {
        ATH79_MACH_RB_751,              /* MikroTik RouterBOARD 751 */
        ATH79_MACH_RB_751G,             /* Mikrotik RouterBOARD 751G */
        ATH79_MACH_RB_951G,             /* Mikrotik RouterBOARD 951G */
index 8e61009..cf27ef5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -49,6 +49,7 @@ enum ath79_mach_type {
+@@ -50,6 +50,7 @@ enum ath79_mach_type {
        ATH79_MACH_EW_DORIN,            /* embedded wireless Dorin Platform */
        ATH79_MACH_EW_DORIN_ROUTER,     /* embedded wireless Dorin Router Platform */
        ATH79_MACH_EAP7660D,            /* Senao EAP7660D */
index aefdd66..8905803 100644 (file)
@@ -28,7 +28,7 @@
  obj-$(CONFIG_ATH79_MACH_TL_WR1043ND)  += mach-tl-wr1043nd.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -123,6 +123,7 @@ enum ath79_mach_type {
+@@ -124,6 +124,7 @@ enum ath79_mach_type {
        ATH79_MACH_TL_WR841N_V1,        /* TP-LINK TL-WR841N v1 */
        ATH79_MACH_TL_WR841N_V7,        /* TP-LINK TL-WR841N/ND v7 */
        ATH79_MACH_TL_WR841N_V8,        /* TP-LINK TL-WR841N/ND v8 */
index 584f1c1..ddc13bc 100644 (file)
@@ -10,7 +10,7 @@
  obj-$(CONFIG_ATH79_MACH_HORNET_UB)    += mach-hornet-ub.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -50,6 +50,7 @@ enum ath79_mach_type {
+@@ -51,6 +51,7 @@ enum ath79_mach_type {
        ATH79_MACH_EW_DORIN_ROUTER,     /* embedded wireless Dorin Router Platform */
        ATH79_MACH_EAP7660D,            /* Senao EAP7660D */
        ATH79_MACH_GS_OOLITE,           /* GS OOLITE V1.0 */
index c213c50..5fb93f2 100644 (file)
@@ -1,13 +1,13 @@
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -129,3 +129,4 @@ obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H)     +
+@@ -130,3 +130,4 @@ obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H)     +
  obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
  obj-$(CONFIG_ATH79_MACH_ZCN_1523H)    += mach-zcn-1523h.o
  obj-$(CONFIG_ATH79_MACH_CARAMBOLA2)   += mach-carambola2.o
 +obj-$(CONFIG_ATH79_MACH_NBG6716)      += mach-nbg6716.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -62,6 +62,7 @@ enum ath79_mach_type {
+@@ -64,6 +64,7 @@ enum ath79_mach_type {
        ATH79_MACH_MZK_W04NU,           /* Planex MZK-W04NU */
        ATH79_MACH_MZK_W300NH,          /* Planex MZK-W300NH */
        ATH79_MACH_NBG460N,             /* Zyxel NBG460N/550N/550NH */
@@ -17,7 +17,7 @@
        ATH79_MACH_OM2P,                /* OpenMesh OM2P */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -889,6 +889,17 @@ config ATH79_MACH_NBG460N
+@@ -899,6 +899,17 @@ config ATH79_MACH_NBG460N
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
index 7d0a41f..c87b1c0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -65,6 +65,7 @@ enum ath79_mach_type {
+@@ -67,6 +67,7 @@ enum ath79_mach_type {
        ATH79_MACH_NBG6716,             /* Zyxel NBG6716 */
        ATH79_MACH_OM2P_HS,             /* OpenMesh OM2P-HS */
        ATH79_MACH_OM2P_LC,             /* OpenMesh OM2P-LC */
index 35709c8..13e03cd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -63,6 +63,7 @@ enum ath79_mach_type {
+@@ -65,6 +65,7 @@ enum ath79_mach_type {
        ATH79_MACH_MZK_W300NH,          /* Planex MZK-W300NH */
        ATH79_MACH_NBG460N,             /* Zyxel NBG460N/550N/550NH */
        ATH79_MACH_NBG6716,             /* Zyxel NBG6716 */
index f6286a1..0c3a8de 100644 (file)
  #include <asm/uaccess.h>
  
  #include <linux/proc_fs.h>
-@@ -763,10 +764,10 @@ static void tcp_v6_send_response(struct
+@@ -763,10 +764,10 @@ static void tcp_v6_send_response(struct 
        topt = (__be32 *)(t1 + 1);
  
        if (tsecr) {
  
 --- a/net/ipv6/ip6_tunnel.c
 +++ b/net/ipv6/ip6_tunnel.c
-@@ -1122,9 +1122,9 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
+@@ -1272,9 +1272,9 @@ ip6ip6_tnl_xmit(struct sk_buff *skb, str
  
        dsfield = ipv6_get_dsfield(ipv6h);
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_TCLASS)
  #include <linux/netdevice.h>
 --- a/include/net/inet_ecn.h
 +++ b/include/net/inet_ecn.h
-@@ -115,13 +115,13 @@ static inline int IP6_ECN_set_ce(struct
+@@ -115,13 +115,13 @@ static inline int IP6_ECN_set_ce(struct 
  {
        if (INET_ECN_is_not_ect(ipv6_get_dsfield(iph)))
                return 0;
        ptr = ip6hoff + sizeof(struct ipv6hdr);
 --- a/net/xfrm/xfrm_input.c
 +++ b/net/xfrm/xfrm_input.c
-@@ -77,8 +77,8 @@ int xfrm_parse_spi(struct sk_buff *skb,
+@@ -77,8 +77,8 @@ int xfrm_parse_spi(struct sk_buff *skb, 
        if (!pskb_may_pull(skb, hlen))
                return -EINVAL;