[package] mac80211: fix reversed WARN_ON() condition which causes a stray stacktrace...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Nov 2011 13:33:11 +0000 (13:33 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Nov 2011 13:33:11 +0000 (13:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29284 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile
package/mac80211/patches/910-fix-reversed-warn-on-workqueue.patch [new file with mode: 0644]

index 25df7aa..aa72941 100644 (file)
@@ -40,6 +40,8 @@ PKG_CONFIG_DEPENDS:= \
 
 CARL9170_FW_VERSION:=1.9.4
 
+#QUILT_PATCH_DIR:=patches-openwrt
+
 include $(INCLUDE_DIR)/package.mk
 
 WMENU:=Wireless Drivers
diff --git a/package/mac80211/patches/910-fix-reversed-warn-on-workqueue.patch b/package/mac80211/patches/910-fix-reversed-warn-on-workqueue.patch
new file mode 100644 (file)
index 0000000..b598574
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/compat/compat-2.6.36.c
++++ b/compat/compat-2.6.36.c
+@@ -101,7 +101,7 @@ EXPORT_SYMBOL_GPL(system_nrt_wq);
+ void compat_system_workqueue_create()
+ {
+       system_nrt_wq = create_singlethread_workqueue("events_nrt");
+-      WARN_ON(system_nrt_wq);
++      WARN_ON(!system_nrt_wq);
+ }
+ void compat_system_workqueue_destroy()