Allow firstboot to mount /dev/mtdblock/4 on /jffs when root fs is squashfs
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 25 Feb 2005 23:56:46 +0000 (23:56 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 25 Feb 2005 23:56:46 +0000 (23:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@293 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/squashfs-lzma/squashfslzmaroot.mk
target/squashfs/squashfsroot.mk

index 722c205..4059896 100644 (file)
@@ -39,6 +39,7 @@ squashfslzma-dirclean:
 squashfslzmaroot: squashfslzma
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/info
+       @mkdir -p $(TARGET_DIR)/jffs
        $(SQUASHFSLZMA_DIR)/squashfs-tools/mksquashfs-lzma $(TARGET_DIR) $(IMAGE).squashfslzma -noappend -root-owned -le
 
 squashfslzmaroot-source: squashfslzma-source
index d3a104a..62b645a 100644 (file)
@@ -38,6 +38,7 @@ squashfs-dirclean:
 squashfsroot: squashfs
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/info
+       @mkdir -p $(TARGET_DIR)/jffs
        $(SQUASHFS_DIR)/squashfs-tools/mksquashfs $(TARGET_DIR) $(IMAGE).squashfs -noappend -root-owned -le
 
 squashfsroot-source: squashfs-source