update to 2.0.2, make http proxy an option, default on, adds 5kb
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 8 Sep 2005 07:49:20 +0000 (07:49 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 8 Sep 2005 07:49:20 +0000 (07:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1878 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/openvpn/Config.in
openwrt/package/openvpn/Makefile

index 72f6835..12c35ba 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_PACKAGE_OPENVPN
-       tristate "openvpn - VPN solution using SSL"
+       tristate "openvpn - Open source VPN solution using SSL"
        default m if CONFIG_DEVEL
        select BR2_PACKAGE_KMOD_TUN
        select BR2_PACKAGE_LIBOPENSSL
@@ -16,6 +16,11 @@ config BR2_PACKAGE_OPENVPN_SERVER
        default y
        depends BR2_PACKAGE_OPENVPN
 
+config BR2_PACKAGE_OPENVPN_HTTP
+       bool "Enable http proxy support"
+       default y
+       depends BR2_PACKAGE_OPENVPN
+
 config BR2_PACKAGE_OPENVPN_LZO
        bool "Enable transparent compression (lzo)"
        default y
index f6a0b5a..bf0ada2 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openvpn
-PKG_VERSION:=2.0.1
-PKG_RELEASE:=2
-PKG_MD5SUM:=fad7a08c0d68371c2c0e6428bcb98fa5
+PKG_VERSION:=2.0.2
+PKG_RELEASE:=1
+PKG_MD5SUM:=862f8788f080f669b1ae00a74ef68001
 
 PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -28,6 +28,9 @@ endif
 ifneq ($(BR2_PACKAGE_OPENVPN_SERVER),y)
 DISABLE_SERVER:=--disable-server
 endif
+ifneq ($(BR2_PACKAGE_OPENVPN_HTTP),y)
+DISABLE_HTTP:=--disable-http
+endif
 
 $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
@@ -62,9 +65,9 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
                  --disable-plugins \
                  --disable-management \
                  --disable-socks \
-                 --disable-http \
                  $(DISABLE_LZO) \
                  $(DISABLE_SERVER) \
+                 $(DISABLE_HTTP) \
        );
        touch $(PKG_BUILD_DIR)/.configured