[package] comgt: fix 3g redialling if dongle is physically reattached (#11567, #12008)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Sep 2012 19:46:38 +0000 (19:46 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Sep 2012 19:46:38 +0000 (19:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33350 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/comgt/Makefile
package/comgt/files/3g.usb

index ef0164e..ae8aa66 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=19
+PKG_RELEASE:=20
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index 1dabc0c..fd6837e 100644 (file)
@@ -10,8 +10,8 @@ find_3g_iface() {
        config_get proto "$cfg" proto
        [ "$proto" = 3g ] || return 0
 
-       local dev
-       config_get dev "$cfg" device
+       # bypass state vars here because 00-netstate could clobber .device
+       local dev=$(uci_get network "$cfg" device)
 
        if [ "${dev##*/}" = "${tty##*/}" ]; then
                if [ "$ACTION" = add ]; then