do not ignore exit codes of quilt anymore (by nbd)
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Jan 2009 22:01:39 +0000 (22:01 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Jan 2009 22:01:39 +0000 (22:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14149 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/quilt.mk

index d3233d8..c47a926 100644 (file)
@@ -126,7 +126,7 @@ define Build/Quilt
 
   $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
   $(STAMP_CHECKED): $(STAMP_PATCHED)
-       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt next >/dev/null 2>&1 && quilt push -a || quilt top >/dev/null 2>&1); fi
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); if quilt next >/dev/null 2>&1; then quilt push -a; else quilt top; fi >/dev/null 2>&1); fi
        touch $$@
 
   quilt-check: $(STAMP_PREPARED) FORCE