add nano
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 Sep 2005 22:28:50 +0000 (22:28 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 19 Sep 2005 22:28:50 +0000 (22:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1945 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile
package/nano/Config.in [new file with mode: 0644]
package/nano/Makefile [new file with mode: 0644]
package/nano/ipkg/nano.control [new file with mode: 0644]

index 55a8bbd..eb48b47 100644 (file)
@@ -17,6 +17,7 @@ source "package/less/Config.in"
 source "package/lua/Config.in"
 source "package/microperl/Config.in"
 source "package/monit/Config.in"
+source "package/nano/Config.in"
 source "package/osiris/Config.in"
 source "package/php4/Config.in"
 source "package/php5/Config.in"
index 067dfea..1e774f1 100644 (file)
@@ -102,6 +102,7 @@ package-$(BR2_PACKAGE_MPD) += mpd
 package-$(BR2_PACKAGE_MT_DAAPD) += mt-daapd
 package-$(BR2_PACKAGE_MTD) += mtd
 package-$(BR2_PACKAGE_MYSQL) += mysql
+package-$(BR2_PACKAGE_NANO) += nano
 package-$(BR2_PACKAGE_NCURSES) += ncurses
 package-$(BR2_PACKAGE_NDISC) += ndisc
 package-$(BR2_PACKAGE_NET_SNMP) += net-snmp
@@ -225,6 +226,7 @@ lighttpd-compile: openssl-compile pcre-compile
 mini_httpd-compile: matrixssl-compile
 mt-daapd-compile: howl-compile libgdbm-compile libid3tag-compile
 mysql-compile: ncurses-compile zlib-compile
+nano-compile: ncurses-compile
 net-snmp-compile: libelf-compile
 nfs-server-compile: portmap-compile
 nmap-compile: uclibc++-compile pcre-compile libpcap-compile
diff --git a/package/nano/Config.in b/package/nano/Config.in
new file mode 100644 (file)
index 0000000..612afdb
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_NANO
+       tristate "nano - An enhanced clone of the Pico text editor"
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBNCURSES
+       help
+         GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone of the Pico text editor..
+         
+         http://www.nano-editor.org/
+         
diff --git a/package/nano/Makefile b/package/nano/Makefile
new file mode 100644 (file)
index 0000000..ca8e95a
--- /dev/null
@@ -0,0 +1,74 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nano
+PKG_VERSION:=1.3.8
+PKG_RELEASE:=1
+PKG_MD5SUM:=20633397bf5d462255f37dfcc7cad4e7
+
+PKG_SOURCE_URL:=http://www.ewtoo.org/~astyanax/nano/dist/v1.3 \
+       http://www.nano-editor.org/dist/v1.3
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,NANO,nano,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include " \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ac_cv_header_regex_h=no \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --disable-static \
+                       --with-gnu-ld \
+                       --disable-rpath \
+                       --enable-tiny \
+                       --disable-glibtest \
+                       --disable-utf8 \
+                       --without-slang \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_NANO):
+       install -d -m0755 $(IDIR_NANO)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/nano $(IDIR_NANO)/usr/bin/
+       $(RSTRIP) $(IDIR_NANO)
+       $(IPKG_BUILD) $(IDIR_NANO) $(PACKAGE_DIR)
+
+mostlyclean:
+       -$(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm -f $(PKG_BUILD_DIR)/.built
+
diff --git a/package/nano/ipkg/nano.control b/package/nano/ipkg/nano.control
new file mode 100644 (file)
index 0000000..fa004b2
--- /dev/null
@@ -0,0 +1,7 @@
+Package: nano
+Priority: optional
+Section: admin
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Oliver Ertl <oliver@ertl-net.net>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/nano/
+Depends: libncurses
+Description: An enhanced clone of the Pico text editor