ramips: Add Airlink101 AR725W board support
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Apr 2014 08:08:31 +0000 (08:08 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Apr 2014 08:08:31 +0000 (08:08 +0000)
Signed-off-by: Claudio Leite <leitec@staticky.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40549 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/dts/AR725W.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt288x/config-3.10

diff --git a/target/linux/ramips/dts/AR725W.dts b/target/linux/ramips/dts/AR725W.dts
new file mode 100644 (file)
index 0000000..87f2553
--- /dev/null
@@ -0,0 +1,113 @@
+/dts-v1/;
+
+/include/ "rt2880.dtsi"
+
+/ {
+       compatible = "AR725W", "ralink,rt2880-soc";
+       model = "Airlink101 AR725W";
+
+       palmbus@300000 {
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "spi", "uartlite";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@400000 {
+               status = "okay";
+               mtd-mac-address = <&factory 0x4>;
+
+               port@0 {
+                       phy-handle = <&phy0>;
+                       phy-mode = "mii";
+               };
+
+               mdio-bus {
+                       status = "okay";
+                       phy0: ethernet-phy@0 {
+                               phy-mode = "mii";
+                               reg = <0>;
+                       };
+               };
+       };
+
+       wmac@480000 {
+               status = "okay";
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       cfi@bdc00000 {
+               compatible = "cfi-flash";
+               reg = <0xbc400000 0x800000>;
+
+               bank-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               u-boot@0 {
+                       reg = <0x0 0x30000>;
+                       label = "u-boot";
+                       read-only;
+               };
+
+               u-boot-env@30000 {
+                       reg = <0x30000 0x10000>;
+                       label = "u-boot-env";
+               };
+
+               factory: factory@40000 {
+                       reg = <0x40000 0x10000>;
+                       label = "factory";
+                       read-only;
+               };
+
+               firmware@50000 {
+                       reg = <0x50000 0x3B0000>;
+                       label = "firmware";
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               status {
+                       label = "ar725w:green:power";
+                       gpios = <&gpio0 7 0>;
+               };
+
+               wpsred {
+                       label = "ar725w:red:wps";
+                       gpios = <&gpio0 8 1>;
+               };
+
+               wpsblue {
+                       label = "ar725w:blue:wps";
+                       gpios = <&gpio0 13 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <100>;
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 0 1>;
+                       linux,code = <0x211>;
+               };
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 9 1>;
+                       linux,code = <0x198>;
+               };
+       };
+};
index 63f7425..bf9ccc1 100644 (file)
@@ -261,6 +261,8 @@ BuildFirmware/PorayDualSize/initramfs=$(call BuildFirmware/DefaultDualSize/initr
 # RT288X Profiles
 #
 
+Image/Build/Profile/AR725W=$(call BuildFirmware/Default4M/$(1),$(1),ar725w,AR725W)
+
 # 0x790000
 belkin_f5d8235v1_mtd_size=7929856
 Image/Build/Profile/F5D8235V1=$(call BuildFirmware/CustomFlash/$(1),$(1),f5d8235v1,F5D8235_V1,$(belkin_f5d8235v1_mtd_size))
@@ -273,6 +275,7 @@ Image/Build/Profile/WLITX4AG300N=$(call BuildFirmware/Default4M/$(1),$(1),wli-tx
 
 ifeq ($(SUBTARGET),rt288x)
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/AR725W,$(1))
        $(call Image/Build/Profile/F5D8235V1,$(1))
        $(call Image/Build/Profile/RTN15,$(1))
        $(call Image/Build/Profile/V11STFE,$(1))
index f1ae652..6fd3971 100644 (file)
@@ -79,6 +79,7 @@ CONFIG_HW_RANDOM=m
 CONFIG_HZ_PERIODIC=y
 CONFIG_IMAGE_CMDLINE_HACK=y
 CONFIG_INITRAMFS_SOURCE=""
+CONFIG_IP17XX_PHY=y
 CONFIG_IRQCHIP=y
 CONFIG_IRQ_CPU=y
 CONFIG_IRQ_DOMAIN=y