[package] 6in4: automatically determine wan interface in hotplug events
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Jul 2010 00:17:31 +0000 (00:17 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Jul 2010 00:17:31 +0000 (00:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22102 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/6in4/Makefile
package/6in4/files/6in4.hotplug

index d88ee16..75e7848 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=2
+PKG_VERSION:=3
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 0a196c2..96b046d 100644 (file)
@@ -14,7 +14,7 @@ if [ "$ACTION" = ifup ]; then
                [ "$proto" = 6in4 ] || return 0
 
                local wandev
-               config_get wandev "$cfg" wan_device
+               config_get wandev "$cfg" wan_device "$(find_6in4_wanif)"
                [ "$wandev" = "$DEVICE" ] || return 0
 
                local oldip