include: image.mk: use correct flag for fixed mtimes with make_ext4fs (#21768)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Feb 2016 13:58:43 +0000 (13:58 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 1 Feb 2016 13:58:43 +0000 (13:58 +0000)
The correct flag for fixed mtime is -T, not -t.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48610 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 2d65508..6868617 100644 (file)
@@ -263,7 +263,7 @@ define Image/mkfs/ext4
                -i $(CONFIG_TARGET_EXT4_MAXINODE) \
                -m $(CONFIG_TARGET_EXT4_RESERVED_PCT) \
                $(if $(CONFIG_TARGET_EXT4_JOURNAL),,-J) \
-               $(if $(SOURCE_DATE_EPOCH),-t $(SOURCE_DATE_EPOCH)) \
+               $(if $(SOURCE_DATE_EPOCH),-T $(SOURCE_DATE_EPOCH)) \
                $(KDIR)/root.ext4 $(TARGET_DIR)/
 endef