image.mk: remove legacy target rules
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Oct 2014 15:01:08 +0000 (15:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Oct 2014 15:01:08 +0000 (15:01 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42881 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 67c9a2f..12322bd 100644 (file)
@@ -259,10 +259,10 @@ define BuildImage
 
   ifeq ($(IB),)
     .PHONY: download prepare compile clean image_prepare mkfs_prepare kernel_prepare install
 
   ifeq ($(IB),)
     .PHONY: download prepare compile clean image_prepare mkfs_prepare kernel_prepare install
-    compile: compile-targets
+    compile:
                $(call Build/Compile)
 
                $(call Build/Compile)
 
-    clean: clean-targets
+    clean:
                $(call Build/Clean)
 
     image_prepare: compile
                $(call Build/Clean)
 
     image_prepare: compile
@@ -279,15 +279,11 @@ define BuildImage
 
   $(foreach fs,$(TARGET_FILESYSTEMS) $(fs-subtypes-y),$(call BuildImage/mkfs,$(fs)))
 
 
   $(foreach fs,$(TARGET_FILESYSTEMS) $(fs-subtypes-y),$(call BuildImage/mkfs,$(fs)))
 
-  install: kernel_prepare install-targets
+  install: kernel_prepare
        $(foreach fs,$(TARGET_FILESYSTEMS),
                $(call Image/Build,$(fs))
        )
        $(call Image/mkfs/ubifs)
        $(call Image/Checksum)
 
        $(foreach fs,$(TARGET_FILESYSTEMS),
                $(call Image/Build,$(fs))
        )
        $(call Image/mkfs/ubifs)
        $(call Image/Checksum)
 
-  compile-targets:
-  install-targets:
-  clean-targets:
-
 endef
 endef