This patch makes kernel modules check if config is defined and creates a config
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 15 May 2008 00:57:50 +0000 (00:57 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 15 May 2008 00:57:50 +0000 (00:57 +0000)
passthrough target which will evaluate the original config in the generated
package. This is done so kernel modules can have configuration menus like
busybox, etc... Signed-off-by: Axel Gembe <ago@bastart.eu.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11139 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index b80c3b6..7d986e4 100644 (file)
@@ -120,6 +120,12 @@ $(call KernelPackage/$(1)/description)
     endef
   endif
 
+  ifdef KernelPackage/$(1)/config
+    define Package/kmod-$(1)/config
+$(call KernelPackage/$(1)/config)
+    endef
+  endif
+
   ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install