kernel: add own Kconfig for OpenWrt mtdsplit drivers
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Aug 2014 16:30:44 +0000 (16:30 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Aug 2014 16:30:44 +0000 (16:30 +0000)
There are pretty many OpenWrt patches against mtd subsystem resulting
in a bit of mess and growing maintenance cost.
My idea is to use an extra "mtdsplit" directory with OpenWrt specific
files (including Kconfig).
This is the first step to achieve this. This patch adds a "mtdsplit"
directory with Kconfig and replaces 4 patches with a single one.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42287 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic/files/drivers/mtd/mtdsplit/Kconfig [new file with mode: 0644]
target/linux/generic/patches-3.14/406-mtd-add-squashfs-parser.patch [deleted file]
target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch [new file with mode: 0644]
target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch [deleted file]
target/linux/generic/patches-3.14/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch [deleted file]
target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch [deleted file]

diff --git a/target/linux/generic/files/drivers/mtd/mtdsplit/Kconfig b/target/linux/generic/files/drivers/mtd/mtdsplit/Kconfig
new file mode 100644 (file)
index 0000000..09794f4
--- /dev/null
@@ -0,0 +1,24 @@
+comment "Rootfs partition parsers"
+
+config MTD_SPLIT_SQUASHFS_ROOT
+       bool "Squashfs based root partition parser"
+       select MTD_SPLIT
+       default n
+       help
+         This provides a parsing function which allows to detect the
+         offset and size of the unused portion of a rootfs partition
+         containing a squashfs.
+
+comment "Firmware partition parsers"
+
+config MTD_SPLIT_SEAMA_FW
+       bool "Seama firmware parser"
+       select MTD_SPLIT
+
+config MTD_SPLIT_UIMAGE_FW
+       bool "uImage based firmware partition parser"
+       select MTD_SPLIT
+
+config MTD_SPLIT_LZMA_FW
+       bool "LZMA compressed kernel based firmware partition parser"
+       select MTD_SPLIT
diff --git a/target/linux/generic/patches-3.14/406-mtd-add-squashfs-parser.patch b/target/linux/generic/patches-3.14/406-mtd-add-squashfs-parser.patch
deleted file mode 100644 (file)
index b3ff9d9..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -37,6 +37,17 @@ config MTD_UIMAGE_SPLIT
-       depends on MTD_SPLIT_FIRMWARE
-       default y
-+comment "Rootfs partition parsers"
-+
-+config MTD_SPLIT_SQUASHFS_ROOT
-+      bool "Squashfs based root partition parser"
-+      select MTD_SPLIT
-+      default n
-+      help
-+        This provides a parsing function which allows to detect the
-+        offset and size of the unused portion of a rootfs partition
-+        containing a squashfs.
-+
- config MTD_SPLIT
-       def_bool n
-       help 
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD)              += mtd.o
- mtd-y                         := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
- mtd-$(CONFIG_MTD_SPLIT)               += mtdsplit.o
-+mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
- obj-$(CONFIG_MTD_OF_PARTS)    += ofpart.o
- obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
diff --git a/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch b/target/linux/generic/patches-3.14/406-mtd-hook-mtdsplit-into-Kbuild.patch
new file mode 100644 (file)
index 0000000..eac31d7
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/Kconfig
++++ b/drivers/mtd/Kconfig
+@@ -37,6 +37,8 @@ config MTD_UIMAGE_SPLIT
+       depends on MTD_SPLIT_FIRMWARE
+       default y
++source "drivers/mtd/mtdsplit/Kconfig"
++
+ config MTD_SPLIT
+       def_bool n
+       help 
+--- a/drivers/mtd/Makefile
++++ b/drivers/mtd/Makefile
+@@ -7,6 +7,10 @@ obj-$(CONFIG_MTD)             += mtd.o
+ mtd-y                         := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
+ mtd-$(CONFIG_MTD_SPLIT)               += mtdsplit.o
++mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
++mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
++mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
++mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
+ obj-$(CONFIG_MTD_OF_PARTS)    += ofpart.o
+ obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
diff --git a/target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch b/target/linux/generic/patches-3.14/407-mtd-hook-mtdsplit_uimage-into-Kbuild.patch
deleted file mode 100644 (file)
index 02697f6..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -48,6 +48,12 @@ config MTD_SPLIT_SQUASHFS_ROOT
-         offset and size of the unused portion of a rootfs partition
-         containing a squashfs.
-+comment "Firmware partition parsers"
-+
-+config MTD_SPLIT_UIMAGE_FW
-+      bool "uImage based firmware partition parser"
-+      select MTD_SPLIT
-+
- config MTD_SPLIT
-       def_bool n
-       help 
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -8,6 +8,7 @@ mtd-y                          := mtdcore.o mtdsuper.o mtdconc
- mtd-$(CONFIG_MTD_SPLIT)               += mtdsplit.o
- mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
-+mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
- obj-$(CONFIG_MTD_OF_PARTS)    += ofpart.o
- obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
diff --git a/target/linux/generic/patches-3.14/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch b/target/linux/generic/patches-3.14/408-mtd-hook-mtdsplit_seama-into-Kbuild.patch
deleted file mode 100644 (file)
index 016a9b6..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -50,6 +50,10 @@ config MTD_SPLIT_SQUASHFS_ROOT
- comment "Firmware partition parsers"
-+config MTD_SPLIT_SEAMA_FW
-+      bool "Seama firmware parser"
-+      select MTD_SPLIT
-+
- config MTD_SPLIT_UIMAGE_FW
-       bool "uImage based firmware partition parser"
-       select MTD_SPLIT
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD)              += mtd.o
- mtd-y                         := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
- mtd-$(CONFIG_MTD_SPLIT)               += mtdsplit.o
-+mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
- mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
- mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
diff --git a/target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch b/target/linux/generic/patches-3.14/409-mtd-hook-mtdsplit_lzma-into-Kbuild.patch
deleted file mode 100644 (file)
index cc9a971..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/drivers/mtd/Kconfig
-+++ b/drivers/mtd/Kconfig
-@@ -58,6 +58,10 @@ config MTD_SPLIT_UIMAGE_FW
-       bool "uImage based firmware partition parser"
-       select MTD_SPLIT
-+config MTD_SPLIT_LZMA_FW
-+      bool "LZMA compressed kernel based firmware partition parser"
-+      select MTD_SPLIT
-+
- config MTD_SPLIT
-       def_bool n
-       help 
---- a/drivers/mtd/Makefile
-+++ b/drivers/mtd/Makefile
-@@ -10,6 +10,7 @@ mtd-$(CONFIG_MTD_SPLIT)              += mtdsplit.o
- mtd-$(CONFIG_MTD_SPLIT_SEAMA_FW) += mtdsplit_seama.o
- mtd-$(CONFIG_MTD_SPLIT_SQUASHFS_ROOT) += mtdsplit_squashfs.o
- mtd-$(CONFIG_MTD_SPLIT_UIMAGE_FW) += mtdsplit_uimage.o
-+mtd-$(CONFIG_MTD_SPLIT_LZMA_FW) += mtdsplit_lzma.o
- obj-$(CONFIG_MTD_OF_PARTS)    += ofpart.o
- obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o