odhcp6c: allow IPv6-config via SLAAC-only if no prefix is requested
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Feb 2013 13:38:47 +0000 (13:38 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Feb 2013 13:38:47 +0000 (13:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35421 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index 7b616c9..30ec89e 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-02-01
+PKG_VERSION:=2013-02-01.1
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=7b3e29a4ff20f1b1e91fa65b5a0631462dbee06d
+PKG_SOURCE_VERSION:=6016539b9b73f3dc45b3df92554fca1b5d6431b7
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
index 99867cd..4bd3a67 100755 (executable)
@@ -9,15 +9,15 @@ proto_dhcpv6_init_config() {
        proto_config_add_string "reqprefix"
        proto_config_add_string "clientid"
        proto_config_add_string "reqopts"
-       proto_config_add_string "allow_slaaconly"
+       proto_config_add_string "noslaaconly"
 }
 
 proto_dhcpv6_setup() {
        local config="$1"
        local iface="$2"
 
-       local reqaddress reqprefix clientid reqopts allow_slaaconly
-       json_get_vars reqaddress reqprefix clientid reqopts allow_slaaconly
+       local reqaddress reqprefix clientid reqopts noslaaconly
+       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly
 
 
        # Configure
@@ -29,7 +29,7 @@ proto_dhcpv6_setup() {
 
        [ -n "$clientid" ] && append opts "-c$clientid"
 
-       [ "$allow_slaaconly" = "1" ] && append opts "-S"
+       [ "$noslaaconly" = "1" ] && append opts "-S"
 
        for opt in $reqopts; do
                append opts "-r$opt"